summaryrefslogtreecommitdiffstats
path: root/third_party/rust/oneshot-uniffi/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/oneshot-uniffi/Cargo.toml')
-rw-r--r--third_party/rust/oneshot-uniffi/Cargo.toml64
1 files changed, 64 insertions, 0 deletions
diff --git a/third_party/rust/oneshot-uniffi/Cargo.toml b/third_party/rust/oneshot-uniffi/Cargo.toml
new file mode 100644
index 0000000000..078a477fb2
--- /dev/null
+++ b/third_party/rust/oneshot-uniffi/Cargo.toml
@@ -0,0 +1,64 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.60.0"
+name = "oneshot-uniffi"
+version = "0.1.5"
+authors = ["Linus Färnstrand <faern@faern.net>"]
+description = """
+Patched version of oneshot specifically for the UniFFI project.
+
+This removes the `loom` target and dependency which helps with UniFFI's downstream consumers.
+"""
+readme = "README.md"
+keywords = [
+ "oneshot",
+ "spsc",
+ "async",
+ "sync",
+ "channel",
+]
+categories = [
+ "asynchronous",
+ "concurrency",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/faern/oneshot"
+
+[[bench]]
+name = "benches"
+harness = false
+
+[dev-dependencies.async-std]
+version = "1"
+features = ["attributes"]
+
+[dev-dependencies.criterion]
+version = "0.3"
+
+[dev-dependencies.tokio]
+version = "1"
+features = [
+ "rt",
+ "rt-multi-thread",
+ "macros",
+ "time",
+]
+
+[features]
+async = []
+default = [
+ "std",
+ "async",
+]
+std = []