summaryrefslogtreecommitdiffstats
path: root/third_party/rust/phf/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/phf/Cargo.toml')
-rw-r--r--third_party/rust/phf/Cargo.toml61
1 files changed, 61 insertions, 0 deletions
diff --git a/third_party/rust/phf/Cargo.toml b/third_party/rust/phf/Cargo.toml
new file mode 100644
index 0000000000..fd2178c905
--- /dev/null
+++ b/third_party/rust/phf/Cargo.toml
@@ -0,0 +1,61 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.60"
+name = "phf"
+version = "0.11.2"
+authors = ["Steven Fackler <sfackler@gmail.com>"]
+description = "Runtime support for perfect hash function data structures"
+readme = "README.md"
+categories = [
+ "data-structures",
+ "no-std",
+]
+license = "MIT"
+repository = "https://github.com/rust-phf/rust-phf"
+resolver = "1"
+
+[package.metadata.docs.rs]
+features = ["macros"]
+
+[package.metadata.playground]
+all-features = false
+default-features = true
+features = ["macros"]
+
+[lib]
+name = "phf"
+path = "src/lib.rs"
+test = false
+
+[dependencies.phf_macros]
+version = "^0.11.2"
+optional = true
+
+[dependencies.phf_shared]
+version = "^0.11.2"
+default-features = false
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+
+[features]
+default = ["std"]
+macros = ["phf_macros"]
+std = ["phf_shared/std"]
+uncased = ["phf_shared/uncased"]
+unicase = [
+ "phf_macros?/unicase",
+ "phf_shared/unicase",
+]