summaryrefslogtreecommitdiffstats
path: root/third_party/rust/plist
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/plist')
-rw-r--r--third_party/rust/plist/Cargo.toml2
-rw-r--r--third_party/rust/plist/src/lib.rs2
-rw-r--r--third_party/rust/plist/src/stream/binary_writer.rs2
3 files changed, 4 insertions, 2 deletions
diff --git a/third_party/rust/plist/Cargo.toml b/third_party/rust/plist/Cargo.toml
index 4829298f4f..f064e35f27 100644
--- a/third_party/rust/plist/Cargo.toml
+++ b/third_party/rust/plist/Cargo.toml
@@ -24,7 +24,7 @@ repository = "https://github.com/ebarnard/rust-plist/"
version = "0.13.0"
[dependencies.indexmap]
-version = "1.0.2"
+version = "2.1.0"
[dependencies.line-wrap]
version = "0.1.1"
diff --git a/third_party/rust/plist/src/lib.rs b/third_party/rust/plist/src/lib.rs
index 0ac048e30d..018bbe7d94 100644
--- a/third_party/rust/plist/src/lib.rs
+++ b/third_party/rust/plist/src/lib.rs
@@ -72,6 +72,8 @@
//! specify a tilde requirement e.g. `plist = "~1.0.3"` in you `Cargo.toml` so that the plist crate
//! is not automatically updated to version 1.1.
+#![allow(warnings)] // Third-party
+
pub mod dictionary;
#[cfg(feature = "enable_unstable_features_that_may_break_with_minor_version_bumps")]
diff --git a/third_party/rust/plist/src/stream/binary_writer.rs b/third_party/rust/plist/src/stream/binary_writer.rs
index 0e04dbe865..690e2092a2 100644
--- a/third_party/rust/plist/src/stream/binary_writer.rs
+++ b/third_party/rust/plist/src/stream/binary_writer.rs
@@ -577,7 +577,7 @@ fn is_even(value: usize) -> bool {
fn value_mut<'a>(
values: &'a mut IndexMap<Value<'static>, ValueState>,
value_index: usize,
-) -> (&'a mut Value<'static>, &'a mut ValueState) {
+) -> (&'a Value<'static>, &'a mut ValueState) {
values
.get_index_mut(value_index)
.expect("internal consistency error")