summaryrefslogtreecommitdiffstats
path: root/third_party/rust/presser/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/presser/Cargo.toml')
-rw-r--r--third_party/rust/presser/Cargo.toml58
1 files changed, 58 insertions, 0 deletions
diff --git a/third_party/rust/presser/Cargo.toml b/third_party/rust/presser/Cargo.toml
new file mode 100644
index 0000000000..49d96e476f
--- /dev/null
+++ b/third_party/rust/presser/Cargo.toml
@@ -0,0 +1,58 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64"
+name = "presser"
+version = "0.3.1"
+authors = [
+ "Embark <opensource@embark-studios.com>",
+ "Gray Olson <gray@grayolson.com",
+]
+publish = true
+description = "A crate to help you copy things into raw buffers without invoking spooky action at a distance (undefined behavior)."
+homepage = "https://github.com/EmbarkStudios/presser"
+documentation = "https://docs.rs/presser"
+readme = "README.md"
+keywords = [
+ "copy",
+ "graphics",
+ "raw",
+ "buffer",
+ "memory",
+]
+categories = [
+ "games",
+ "memory-management",
+ "graphics",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/EmbarkStudios/presser"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docs_build",
+]
+
+[lib]
+test = true
+doctest = true
+
+[dependencies]
+
+[dev-dependencies]
+
+[features]
+default = ["std"]
+std = []