summaryrefslogtreecommitdiffstats
path: root/third_party/rust/relevancy/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/relevancy/Cargo.toml47
1 files changed, 47 insertions, 0 deletions
diff --git a/third_party/rust/relevancy/Cargo.toml b/third_party/rust/relevancy/Cargo.toml
new file mode 100644
index 0000000000..eddd8fd25c
--- /dev/null
+++ b/third_party/rust/relevancy/Cargo.toml
@@ -0,0 +1,47 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "relevancy"
+version = "0.1.0"
+exclude = [
+ "/android",
+ "/ios",
+]
+license = "MPL-2.0"
+
+[lib]
+
+[[bin]]
+name = "generate-test-data"
+
+[dependencies]
+log = "0.4"
+md-5 = "0.10"
+parking_lot = ">=0.11,<=0.12"
+thiserror = "1.0"
+uniffi = "0.27.1"
+url = "2.5"
+
+[dependencies.error-support]
+path = "../support/error"
+
+[dependencies.rusqlite]
+version = "0.30.0"
+features = ["bundled"]
+
+[dependencies.sql-support]
+path = "../support/sql"
+
+[build-dependencies.uniffi]
+version = "0.27.1"
+features = ["build"]