summaryrefslogtreecommitdiffstats
path: root/third_party/rust/rure/examples/compile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xthird_party/rust/rure/examples/compile9
1 files changed, 9 insertions, 0 deletions
diff --git a/third_party/rust/rure/examples/compile b/third_party/rust/rure/examples/compile
new file mode 100755
index 0000000000..a7566b791d
--- /dev/null
+++ b/third_party/rust/rure/examples/compile
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+set -ex
+
+# N.B. Add `--release` flag to `cargo build` to make the example run faster.
+cargo build --manifest-path ../Cargo.toml
+gcc -O3 -DDEBUG -o iter iter.c -ansi -Wall -I../include -L../../target/debug -lrure
+# If you're using librure.a, then you'll need to link other stuff:
+# -lutil -ldl -lpthread -lgcc_s -lc -lm -lrt -lutil -lrure