summaryrefslogtreecommitdiffstats
path: root/third_party/rust/subtle/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/subtle/Cargo.toml')
-rw-r--r--third_party/rust/subtle/Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/third_party/rust/subtle/Cargo.toml b/third_party/rust/subtle/Cargo.toml
new file mode 100644
index 0000000000..351989ace0
--- /dev/null
+++ b/third_party/rust/subtle/Cargo.toml
@@ -0,0 +1,38 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "subtle"
+version = "2.5.0"
+authors = ["Isis Lovecruft <isis@patternsinthevoid.net>", "Henry de Valence <hdevalence@hdevalence.ca>"]
+exclude = ["**/.gitignore", ".travis.yml"]
+description = "Pure-Rust traits and utilities for constant-time cryptographic implementations."
+homepage = "https://dalek.rs/"
+documentation = "https://docs.rs/subtle"
+readme = "README.md"
+keywords = ["cryptography", "crypto", "constant-time", "utilities"]
+categories = ["cryptography", "no-std"]
+license = "BSD-3-Clause"
+repository = "https://github.com/dalek-cryptography/subtle"
+[dev-dependencies.rand]
+version = "0.8"
+
+[features]
+const-generics = []
+core_hint_black_box = []
+default = ["std", "i128"]
+i128 = []
+nightly = []
+std = []
+[badges.travis-ci]
+branch = "master"
+repository = "dalek-cryptography/subtle"