summaryrefslogtreecommitdiffstats
path: root/third_party/rust/thiserror-impl/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/thiserror-impl/Cargo.toml')
-rw-r--r--third_party/rust/thiserror-impl/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/third_party/rust/thiserror-impl/Cargo.toml b/third_party/rust/thiserror-impl/Cargo.toml
new file mode 100644
index 0000000000..fffdf5c3a4
--- /dev/null
+++ b/third_party/rust/thiserror-impl/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.56"
+name = "thiserror-impl"
+version = "1.0.56"
+authors = ["David Tolnay <dtolnay@gmail.com>"]
+description = "Implementation detail of the `thiserror` crate"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/thiserror"
+
+[package.metadata.docs.rs]
+rustdoc-args = ["--generate-link-to-definition"]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[lib]
+proc-macro = true
+
+[dependencies.proc-macro2]
+version = "1.0.74"
+
+[dependencies.quote]
+version = "1.0.35"
+
+[dependencies.syn]
+version = "2.0.46"