summaryrefslogtreecommitdiffstats
path: root/third_party/rust/uniffi-example-todolist
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/uniffi-example-todolist/.cargo-checksum.json2
-rw-r--r--third_party/rust/uniffi-example-todolist/Cargo.toml6
-rw-r--r--third_party/rust/uniffi-example-todolist/tests/bindings/test_todolist.py4
-rw-r--r--third_party/rust/uniffi-example-todolist/tests/bindings/test_todolist.rb6
4 files changed, 9 insertions, 9 deletions
diff --git a/third_party/rust/uniffi-example-todolist/.cargo-checksum.json b/third_party/rust/uniffi-example-todolist/.cargo-checksum.json
index a0bf1d826c..6b3a53fc5e 100644
--- a/third_party/rust/uniffi-example-todolist/.cargo-checksum.json
+++ b/third_party/rust/uniffi-example-todolist/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"Cargo.toml":"cb308f7bd5299ed45a3bd516390e21e28d0b02a1913e25917e30e9b8ebe084e3","build.rs":"709d073560a66876d2b975f5145a2dc36e1e3420d79328c8b62666526cae5b2d","src/lib.rs":"ccf6851beb2a3e481541dd8a3c3e3d2fbd513a410eef820221942098212a8184","src/todolist.udl":"1f8a24049c2340b9184e95facfc191ecdcb91541729ae7f20b4625d67685f13c","tests/bindings/test_todolist.kts":"f3d29b48e0193563fc4f131d91ea697f758174dcdb80ea554f233949e575bf55","tests/bindings/test_todolist.py":"f7430af9347df0daa954d38bc2203ce400affbb9a53fced4bb67a6796afa0664","tests/bindings/test_todolist.rb":"6524b5271a9cc0e2d78ca9f86ccb6973889926688a0843b4505a4f62d48f6dcb","tests/bindings/test_todolist.swift":"d1911b85fe0c8c0b42e5421b5af5d7359c9a65bba477d23560eb4b0f52e80662","tests/test_generated_bindings.rs":"46ef1fbedaac0c4867812ef2632a641eab36ab0ee12f5757567dd037aeddcbd3"},"package":null} \ No newline at end of file
+{"files":{"Cargo.toml":"9b182bf2d363240fe1f7b41c73da4bde96d87562812885e4f3175cb6b92ea56b","build.rs":"709d073560a66876d2b975f5145a2dc36e1e3420d79328c8b62666526cae5b2d","src/lib.rs":"ccf6851beb2a3e481541dd8a3c3e3d2fbd513a410eef820221942098212a8184","src/todolist.udl":"1f8a24049c2340b9184e95facfc191ecdcb91541729ae7f20b4625d67685f13c","tests/bindings/test_todolist.kts":"f3d29b48e0193563fc4f131d91ea697f758174dcdb80ea554f233949e575bf55","tests/bindings/test_todolist.py":"8ea1377fe336adaf4cade0fe073ae5825c3b38c63e46b7f4e92b87c0fe57c036","tests/bindings/test_todolist.rb":"e8840eb81477048718a56c5fa02c0fb2e28cf0a598a20c9393ba2262d6ffb89b","tests/bindings/test_todolist.swift":"d1911b85fe0c8c0b42e5421b5af5d7359c9a65bba477d23560eb4b0f52e80662","tests/test_generated_bindings.rs":"46ef1fbedaac0c4867812ef2632a641eab36ab0ee12f5757567dd037aeddcbd3"},"package":null} \ No newline at end of file
diff --git a/third_party/rust/uniffi-example-todolist/Cargo.toml b/third_party/rust/uniffi-example-todolist/Cargo.toml
index 9421e726a0..cf4de491cd 100644
--- a/third_party/rust/uniffi-example-todolist/Cargo.toml
+++ b/third_party/rust/uniffi-example-todolist/Cargo.toml
@@ -29,15 +29,15 @@ once_cell = "1.12"
thiserror = "1.0"
[dependencies.uniffi]
-version = "0.25"
+version = "0.27"
path = "../../uniffi"
[dev-dependencies.uniffi]
-version = "0.25"
+version = "0.27"
path = "../../uniffi"
features = ["bindgen-tests"]
[build-dependencies.uniffi]
-version = "0.25"
+version = "0.27"
path = "../../uniffi"
features = ["build"]
diff --git a/third_party/rust/uniffi-example-todolist/tests/bindings/test_todolist.py b/third_party/rust/uniffi-example-todolist/tests/bindings/test_todolist.py
index 017e999fb2..7b676c83de 100644
--- a/third_party/rust/uniffi-example-todolist/tests/bindings/test_todolist.py
+++ b/third_party/rust/uniffi-example-todolist/tests/bindings/test_todolist.py
@@ -2,7 +2,7 @@ from todolist import *
todo = TodoList()
-entry = TodoEntry("Write bindings for strings in records")
+entry = TodoEntry(text="Write bindings for strings in records")
todo.add_item("Write python bindings")
@@ -20,7 +20,7 @@ assert(todo.get_last_entry().text == "Write bindings for strings in records")
todo.add_item("Test Ünicode hàndling without an entry can't believe I didn't test this at first 🤣")
assert(todo.get_last() == "Test Ünicode hàndling without an entry can't believe I didn't test this at first 🤣")
-entry2 = TodoEntry("Test Ünicode hàndling in an entry can't believe I didn't test this at first 🤣")
+entry2 = TodoEntry(text="Test Ünicode hàndling in an entry can't believe I didn't test this at first 🤣")
todo.add_entry(entry2)
assert(todo.get_last_entry().text == "Test Ünicode hàndling in an entry can't believe I didn't test this at first 🤣")
diff --git a/third_party/rust/uniffi-example-todolist/tests/bindings/test_todolist.rb b/third_party/rust/uniffi-example-todolist/tests/bindings/test_todolist.rb
index d9e04f92e7..fc1a823f52 100644
--- a/third_party/rust/uniffi-example-todolist/tests/bindings/test_todolist.rb
+++ b/third_party/rust/uniffi-example-todolist/tests/bindings/test_todolist.rb
@@ -7,7 +7,7 @@ include Test::Unit::Assertions
include Todolist
todo = TodoList.new
-entry = TodoEntry.new 'Write bindings for strings in records'
+entry = TodoEntry.new(text: 'Write bindings for strings in records')
todo.add_item('Write ruby bindings')
@@ -25,7 +25,7 @@ assert_equal todo.get_last_entry.text, 'Write bindings for strings in records'
todo.add_item("Test Ünicode hàndling without an entry can't believe I didn't test this at first 🤣")
assert_equal todo.get_last, "Test Ünicode hàndling without an entry can't believe I didn't test this at first 🤣"
-entry2 = TodoEntry.new("Test Ünicode hàndling in an entry can't believe I didn't test this at first 🤣")
+entry2 = TodoEntry.new(text: "Test Ünicode hàndling in an entry can't believe I didn't test this at first 🤣")
todo.add_entry(entry2)
assert_equal todo.get_last_entry.text, "Test Ünicode hàndling in an entry can't believe I didn't test this at first 🤣"
@@ -44,4 +44,4 @@ todo.add_item "Test liveness after being demoted from default"
assert todo.get_last == "Test liveness after being demoted from default"
todo2.add_item "Test shared state through local vs default reference"
-assert Todolist.get_default_list.get_last == "Test shared state through local vs default reference" \ No newline at end of file
+assert Todolist.get_default_list.get_last == "Test shared state through local vs default reference"