summaryrefslogtreecommitdiffstats
path: root/third_party/rust/uniffi_bindgen/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/uniffi_bindgen/Cargo.toml15
1 files changed, 10 insertions, 5 deletions
diff --git a/third_party/rust/uniffi_bindgen/Cargo.toml b/third_party/rust/uniffi_bindgen/Cargo.toml
index 9469a9cf25..f0c7af8665 100644
--- a/third_party/rust/uniffi_bindgen/Cargo.toml
+++ b/third_party/rust/uniffi_bindgen/Cargo.toml
@@ -12,11 +12,12 @@
[package]
edition = "2021"
name = "uniffi_bindgen"
-version = "0.25.3"
+version = "0.27.1"
authors = ["Firefox Sync Team <sync-team@mozilla.com>"]
description = "a multi-language bindings generator for rust (codegen and cli tooling)"
homepage = "https://mozilla.github.io/uniffi-rs"
documentation = "https://mozilla.github.io/uniffi-rs"
+readme = "README.md"
keywords = [
"ffi",
"bindgen",
@@ -54,7 +55,7 @@ version = "2.7.0"
version = "0.3"
[dependencies.goblin]
-version = "0.6"
+version = "0.8"
[dependencies.heck]
version = "0.4"
@@ -67,15 +68,19 @@ version = "1.0"
[dependencies.serde]
version = "1"
+features = ["derive"]
+
+[dependencies.textwrap]
+version = "0.16"
[dependencies.toml]
version = "0.5"
[dependencies.uniffi_meta]
-version = "=0.25.3"
+version = "=0.27.1"
[dependencies.uniffi_testing]
-version = "=0.25.3"
+version = "=0.27.1"
[dependencies.uniffi_udl]
-version = "=0.25.3"
+version = "=0.27.1"