summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wast/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/wast/Cargo.toml13
1 files changed, 11 insertions, 2 deletions
diff --git a/third_party/rust/wast/Cargo.toml b/third_party/rust/wast/Cargo.toml
index e2ac927aa5..7f2d159a8b 100644
--- a/third_party/rust/wast/Cargo.toml
+++ b/third_party/rust/wast/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2021"
name = "wast"
-version = "70.0.1"
+version = "201.0.0"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
description = """
Customizable Rust parsers for the WebAssembly Text formats WAT and WAST
@@ -27,6 +27,9 @@ repository = "https://github.com/bytecodealliance/wasm-tools/tree/main/crates/wa
name = "parse-fail"
harness = false
+[dependencies.bumpalo]
+version = "3.14.0"
+
[dependencies.leb128]
version = "0.2.4"
@@ -37,7 +40,7 @@ version = "2.4.1"
version = "0.1.9"
[dependencies.wasm-encoder]
-version = "0.40.0"
+version = "0.201.0"
[dev-dependencies.anyhow]
version = "1.0.58"
@@ -48,3 +51,9 @@ version = "1.3"
[features]
default = ["wasm-module"]
wasm-module = []
+
+[lints.clippy]
+all = "allow"
+
+[lints.rust]
+unsafe_code = "deny"