summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wgpu-types
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/wgpu-types/.cargo-checksum.json2
-rw-r--r--third_party/rust/wgpu-types/Cargo.toml6
-rw-r--r--third_party/rust/wgpu-types/src/lib.rs29
3 files changed, 25 insertions, 12 deletions
diff --git a/third_party/rust/wgpu-types/.cargo-checksum.json b/third_party/rust/wgpu-types/.cargo-checksum.json
index dea747bd18..928cdbab21 100644
--- a/third_party/rust/wgpu-types/.cargo-checksum.json
+++ b/third_party/rust/wgpu-types/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"Cargo.toml":"c536ec4d70291834fb3e6bcd6f03900bb3a651eda9449e7adf03ef2611be96a9","LICENSE.APACHE":"a6cba85bc92e0cff7a450b1d873c0eaa2e9fc96bf472df0247a26bec77bf3ff9","LICENSE.MIT":"c7fea58d1cfe49634cd92e54fc10a9d871f4b275321a4cd8c09e449122caaeb4","src/assertions.rs":"3fe98027aa73970c8ab7874a3e13dbfd6faa87df2081beb5c83aeec4c60f372f","src/lib.rs":"bafa964caee2fdc6fc2adbb1dea540d5575e29c45946bc51e9912bfbdb13a352","src/math.rs":"4d03039736dd6926feb139bc68734cb59df34ede310427bbf059e5c925e0af3b"},"package":null} \ No newline at end of file
+{"files":{"Cargo.toml":"0bcb9c2d557d01677740fea4690c79544898fe749880a72512dca33db171e590","LICENSE.APACHE":"a6cba85bc92e0cff7a450b1d873c0eaa2e9fc96bf472df0247a26bec77bf3ff9","LICENSE.MIT":"c7fea58d1cfe49634cd92e54fc10a9d871f4b275321a4cd8c09e449122caaeb4","src/assertions.rs":"3fe98027aa73970c8ab7874a3e13dbfd6faa87df2081beb5c83aeec4c60f372f","src/lib.rs":"b9fda00d1b61364cdd7e544aee731ce075ea8403349ed286711d39aa8d414c28","src/math.rs":"4d03039736dd6926feb139bc68734cb59df34ede310427bbf059e5c925e0af3b"},"package":null} \ No newline at end of file
diff --git a/third_party/rust/wgpu-types/Cargo.toml b/third_party/rust/wgpu-types/Cargo.toml
index 792b03dcc8..c6f8b3002d 100644
--- a/third_party/rust/wgpu-types/Cargo.toml
+++ b/third_party/rust/wgpu-types/Cargo.toml
@@ -11,7 +11,7 @@
[package]
edition = "2021"
-rust-version = "1.70"
+rust-version = "1.74"
name = "wgpu-types"
version = "0.19.0"
authors = ["gfx-rs developers"]
@@ -56,10 +56,10 @@ fragile-send-sync-non-atomic-wasm = []
strict_asserts = []
[target."cfg(target_arch = \"wasm32\")".dependencies]
-js-sys = "0.3.67"
+js-sys = "0.3.69"
[target."cfg(target_arch = \"wasm32\")".dependencies.web-sys]
-version = "0.3.67"
+version = "0.3.69"
features = [
"ImageBitmap",
"HtmlVideoElement",
diff --git a/third_party/rust/wgpu-types/src/lib.rs b/third_party/rust/wgpu-types/src/lib.rs
index 347aad76f9..b36801e941 100644
--- a/third_party/rust/wgpu-types/src/lib.rs
+++ b/third_party/rust/wgpu-types/src/lib.rs
@@ -337,7 +337,7 @@ bitflags::bitflags! {
/// For arbitrary timestamp write commands on encoders refer to [`Features::TIMESTAMP_QUERY_INSIDE_ENCODERS`].
/// For arbitrary timestamp write commands on passes refer to [`Features::TIMESTAMP_QUERY_INSIDE_PASSES`].
///
- /// They must be resolved using [`CommandEncoder::resolve_query_sets`] into a buffer,
+ /// They must be resolved using [`CommandEncoder::resolve_query_set`] into a buffer,
/// then the result must be multiplied by the timestamp period [`Queue::get_timestamp_period`]
/// to get the timestamp in nanoseconds. Multiple timestamps can then be diffed to get the
/// time for operations between them to finish.
@@ -480,10 +480,10 @@ bitflags::bitflags! {
// API:
/// Enables use of Pipeline Statistics Queries. These queries tell the count of various operations
- /// performed between the start and stop call. Call [`RenderPassEncoder::begin_pipeline_statistics_query`] to start
- /// a query, then call [`RenderPassEncoder::end_pipeline_statistics_query`] to stop one.
+ /// performed between the start and stop call. Call [`RenderPass::begin_pipeline_statistics_query`] to start
+ /// a query, then call [`RenderPass::end_pipeline_statistics_query`] to stop one.
///
- /// They must be resolved using [`CommandEncoder::resolve_query_sets`] into a buffer.
+ /// They must be resolved using [`CommandEncoder::resolve_query_set`] into a buffer.
/// The rules on how these resolve into buffers are detailed in the documentation for [`PipelineStatisticsTypes`].
///
/// Supported Platforms:
@@ -511,8 +511,8 @@ bitflags::bitflags! {
/// Implies [`Features::TIMESTAMP_QUERY`] & [`Features::TIMESTAMP_QUERY_INSIDE_ENCODERS`] is supported.
///
/// Additionally allows for timestamp queries to be used inside render & compute passes using:
- /// - [`RenderPassEncoder::write_timestamp`]
- /// - [`ComputePassEncoder::write_timestamp`]
+ /// - [`RenderPass::write_timestamp`]
+ /// - [`ComputePass::write_timestamp`]
///
/// Supported platforms:
/// - Vulkan
@@ -682,7 +682,14 @@ bitflags::bitflags! {
/// Allows the user to call [`RenderPass::set_push_constants`], provide a non-empty array
/// to [`PipelineLayoutDescriptor`], and provide a non-zero limit to [`Limits::max_push_constant_size`].
///
- /// A block of push constants can be declared with `layout(push_constant) uniform Name {..}` in shaders.
+ /// A block of push constants can be declared in WGSL with `var<push_constant>`:
+ ///
+ /// ```rust,ignore
+ /// struct PushConstants { example: f32, }
+ /// var<push_constant> c: PushConstants;
+ /// ```
+ ///
+ /// In GLSL, this corresponds to `layout(push_constant) uniform Name {..}`.
///
/// Supported platforms:
/// - DX12
@@ -7183,7 +7190,7 @@ mod send_sync {
///
/// Corresponds to [WebGPU `GPUDeviceLostReason`](https://gpuweb.github.io/gpuweb/#enumdef-gpudevicelostreason).
#[repr(u8)]
-#[derive(Debug, Copy, Clone)]
+#[derive(Debug, Copy, Clone, Eq, PartialEq)]
pub enum DeviceLostReason {
/// Triggered by driver
Unknown = 0,
@@ -7203,4 +7210,10 @@ pub enum DeviceLostReason {
/// exactly once before it is dropped, which helps with managing the
/// memory owned by the callback.
ReplacedCallback = 3,
+ /// When setting the callback, but the device is already invalid
+ ///
+ /// As above, when the callback is provided, wgpu guarantees that it
+ /// will eventually be called. If the device is already invalid, wgpu
+ /// will call the callback immediately, with this reason.
+ DeviceInvalid = 4,
}