summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wio/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/wio/Cargo.toml')
-rw-r--r--third_party/rust/wio/Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/third_party/rust/wio/Cargo.toml b/third_party/rust/wio/Cargo.toml
new file mode 100644
index 0000000000..2e1c29ab2a
--- /dev/null
+++ b/third_party/rust/wio/Cargo.toml
@@ -0,0 +1,28 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "wio"
+version = "0.2.2"
+authors = ["Peter Atashian <retep998@gmail.com>"]
+include = ["/src/**/*", "/Cargo.toml", "/LICENSE-MIT", "/LICENSE-APACHE", "/build.rs", "/README.md"]
+description = "Windows IO wrapper"
+readme = "README.md"
+keywords = ["windows", "ffi", "win32", "com"]
+categories = ["api-bindings", "os::windows-apis"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/retep998/wio-rs"
+[dependencies.winapi]
+version = "0.3"
+features = ["consoleapi", "errhandlingapi", "fileapi", "handleapi", "minwindef", "processthreadsapi", "std", "unknwnbase", "wincon", "winnt"]
+[dev-dependencies.rand]
+version = "0.4"