summaryrefslogtreecommitdiffstats
path: root/third_party/rust/yoke-derive/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/yoke-derive/Cargo.toml')
-rw-r--r--third_party/rust/yoke-derive/Cargo.toml58
1 files changed, 58 insertions, 0 deletions
diff --git a/third_party/rust/yoke-derive/Cargo.toml b/third_party/rust/yoke-derive/Cargo.toml
new file mode 100644
index 0000000000..8bd87a5f35
--- /dev/null
+++ b/third_party/rust/yoke-derive/Cargo.toml
@@ -0,0 +1,58 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "yoke-derive"
+version = "0.7.3"
+authors = ["Manish Goregaokar <manishsmail@gmail.com>"]
+description = "Custom derive for the yoke crate"
+readme = "README.md"
+keywords = [
+ "zerocopy",
+ "serialization",
+ "lifetime",
+ "borrow",
+ "self-referential",
+]
+categories = [
+ "data-structures",
+ "memory-management",
+ "caching",
+ "no-std",
+]
+license-file = "LICENSE"
+repository = "https://github.com/unicode-org/icu4x"
+
+[package.metadata.workspaces]
+independent = true
+
+[lib]
+path = "src/lib.rs"
+proc_macro = true
+
+[dependencies.proc-macro2]
+version = "1.0.27"
+
+[dependencies.quote]
+version = "1.0.9"
+
+[dependencies.syn]
+version = "2"
+features = [
+ "derive",
+ "fold",
+]
+
+[dependencies.synstructure]
+version = "0.13"
+
+[dev-dependencies]