summaryrefslogtreecommitdiffstats
path: root/third_party/rust/zerofrom/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/zerofrom/Cargo.toml')
-rw-r--r--third_party/rust/zerofrom/Cargo.toml54
1 files changed, 54 insertions, 0 deletions
diff --git a/third_party/rust/zerofrom/Cargo.toml b/third_party/rust/zerofrom/Cargo.toml
new file mode 100644
index 0000000000..a0da76d792
--- /dev/null
+++ b/third_party/rust/zerofrom/Cargo.toml
@@ -0,0 +1,54 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "zerofrom"
+version = "0.1.2"
+authors = ["Manish Goregaokar <manishsmail@gmail.com>"]
+include = [
+ "src/**/*",
+ "examples/**/*",
+ "benches/**/*",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "ZeroFrom trait for constructing"
+readme = "README.md"
+keywords = [
+ "zerocopy",
+ "serialization",
+ "lifetime",
+ "borrow",
+]
+categories = [
+ "data-structures",
+ "caching",
+ "no-std",
+]
+license = "Unicode-DFS-2016"
+repository = "https://github.com/unicode-org/icu4x"
+
+[package.metadata.workspaces]
+independent = true
+
+[package.metadata.docs.rs]
+all-features = true
+
+[dependencies.zerofrom-derive]
+version = "0.1.1"
+optional = true
+
+[features]
+alloc = []
+default = ["alloc"]
+derive = ["dep:zerofrom-derive"]