summaryrefslogtreecommitdiffstats
path: root/toolkit/components/telemetry/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/components/telemetry/Makefile.in')
-rw-r--r--toolkit/components/telemetry/Makefile.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/toolkit/components/telemetry/Makefile.in b/toolkit/components/telemetry/Makefile.in
new file mode 100644
index 0000000000..d61114f9d8
--- /dev/null
+++ b/toolkit/components/telemetry/Makefile.in
@@ -0,0 +1,13 @@
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include $(topsrcdir)/config/rules.mk
+
+# This is so hacky. Waiting on bug 988938.
+addondir = $(srcdir)/tests/addons
+testdir = $(topobjdir)/_tests/xpcshell/toolkit/components/telemetry/tests/unit
+
+misc:: $(call mkdir_deps,$(testdir))
+ $(foreach dir,$(wildcard $(addondir)/*),$(call py_action,zip $(notdir $(dir)).xpi,-C $(dir) $(testdir)/$(notdir $(dir)).xpi \*))