summaryrefslogtreecommitdiffstats
path: root/toolkit/components/uniffi-fixtures/custom-types/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/components/uniffi-fixtures/custom-types/Cargo.toml')
-rw-r--r--toolkit/components/uniffi-fixtures/custom-types/Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/toolkit/components/uniffi-fixtures/custom-types/Cargo.toml b/toolkit/components/uniffi-fixtures/custom-types/Cargo.toml
new file mode 100644
index 0000000000..a05324952e
--- /dev/null
+++ b/toolkit/components/uniffi-fixtures/custom-types/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "uniffi-example-custom-types"
+edition = "2021"
+version = "0.19.6"
+authors = ["Firefox Sync Team <sync-team@mozilla.com>"]
+license = "MPL-2.0"
+publish = false
+
+[lib]
+crate-type = ["lib", "cdylib"]
+name = "uniffi_custom_types"
+
+[dependencies]
+anyhow = "1"
+bytes = "1.0"
+serde_json = "1"
+uniffi = { workspace = true }
+url = "2.4"
+
+[build-dependencies]
+uniffi = { workspace = true, features = ["build"] }