summaryrefslogtreecommitdiffstats
path: root/toolkit/crashreporter/client/app/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/crashreporter/client/app/Makefile.in')
-rw-r--r--toolkit/crashreporter/client/app/Makefile.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/toolkit/crashreporter/client/app/Makefile.in b/toolkit/crashreporter/client/app/Makefile.in
new file mode 100644
index 0000000000..39fa3c8fbb
--- /dev/null
+++ b/toolkit/crashreporter/client/app/Makefile.in
@@ -0,0 +1,17 @@
+# vim:set ts=8 sw=8 sts=8 noet:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+ifeq ($(OS_ARCH),Darwin)
+
+include $(topsrcdir)/config/rules.mk
+
+libs::
+ $(NSINSTALL) -D $(DIST)/bin/crashreporter.app
+ rsync --archive --cvs-exclude --exclude '*.in' $(srcdir)/macos_app_bundle/ $(DIST)/bin/crashreporter.app/Contents/
+ $(call py_action,preprocessor crashreporter.app/Contents/Resources/English.lproj/InfoPlist.strings,-Fsubstitution --output-encoding utf-16 -DAPP_NAME='$(MOZ_APP_DISPLAYNAME)' $(srcdir)/macos_app_bundle/Resources/English.lproj/InfoPlist.strings.in -o $(DIST)/bin/crashreporter.app/Contents/Resources/English.lproj/InfoPlist.strings)
+ $(NSINSTALL) -D $(DIST)/bin/crashreporter.app/Contents/MacOS
+ $(NSINSTALL) $(DIST)/bin/crashreporter $(DIST)/bin/crashreporter.app/Contents/MacOS
+
+endif