summaryrefslogtreecommitdiffstats
path: root/toolkit/library
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/library')
-rw-r--r--toolkit/library/build/moz.build2
-rw-r--r--toolkit/library/gen_buildid.py11
-rw-r--r--toolkit/library/gtest/rust/lib.rs2
-rw-r--r--toolkit/library/rust/shared/Cargo.toml20
4 files changed, 13 insertions, 22 deletions
diff --git a/toolkit/library/build/moz.build b/toolkit/library/build/moz.build
index df0afaab84..154edbeab3 100644
--- a/toolkit/library/build/moz.build
+++ b/toolkit/library/build/moz.build
@@ -28,7 +28,7 @@ if CONFIG["COMPILE_ENVIRONMENT"]:
"dependentlibs.list.gtest",
script="dependentlibs.py",
entry_point="gen_list",
- inputs=["!%s" % full_libname],
+ inputs=["!/dist/bin/%s" % full_libname],
)
FINAL_TARGET_FILES += ["!dependentlibs.list", "!dependentlibs.list.gtest"]
diff --git a/toolkit/library/gen_buildid.py b/toolkit/library/gen_buildid.py
index 9943ad2539..0078a5cfd6 100644
--- a/toolkit/library/gen_buildid.py
+++ b/toolkit/library/gen_buildid.py
@@ -18,16 +18,7 @@ from mozbuild.preprocessor import Preprocessor
def main(output, input_file):
with open(input_file) as fh:
- if buildconfig.substs["EXPAND_LIBS_LIST_STYLE"] == "linkerscript":
-
- def cleanup(line):
- assert line.startswith('INPUT("')
- assert line.endswith('")')
- return line[len('INPUT("') : -len('")')]
-
- objs = [cleanup(l.strip()) for l in fh.readlines()]
- else:
- objs = [l.strip() for l in fh.readlines()]
+ objs = [l.strip() for l in fh.readlines()]
pp = Preprocessor()
pp.out = StringIO()
diff --git a/toolkit/library/gtest/rust/lib.rs b/toolkit/library/gtest/rust/lib.rs
index 218353ee2e..87f3af5e6b 100644
--- a/toolkit/library/gtest/rust/lib.rs
+++ b/toolkit/library/gtest/rust/lib.rs
@@ -4,6 +4,7 @@
extern crate bench_collections_gtest;
extern crate dap_ffi_gtest;
+extern crate dllservices_gtest;
extern crate fog_gtest;
#[cfg(feature = "gecko-fuzz-targets")]
extern crate gecko_fuzz_targets;
@@ -13,4 +14,3 @@ extern crate moz_task_gtest;
extern crate mp4parse_gtest;
extern crate nsstring_gtest;
extern crate xpcom_gtest;
-extern crate dllservices_gtest;
diff --git a/toolkit/library/rust/shared/Cargo.toml b/toolkit/library/rust/shared/Cargo.toml
index 70f783a00f..8927ad1041 100644
--- a/toolkit/library/rust/shared/Cargo.toml
+++ b/toolkit/library/rust/shared/Cargo.toml
@@ -22,7 +22,7 @@ static_prefs = { path = "../../../../modules/libpref/init/static_prefs" }
profiler_helper = { path = "../../../../tools/profiler/rust-helper", optional = true }
mozurl = { path = "../../../../netwerk/base/mozurl" }
webrender_bindings = { path = "../../../../gfx/webrender_bindings" }
-cubeb-coreaudio = { git = "https://github.com/mozilla/cubeb-coreaudio-rs", rev = "cc58f92f28015e4e25eba9e482007cf464c10474", optional = true }
+cubeb-coreaudio = { git = "https://github.com/mozilla/cubeb-coreaudio-rs", rev = "4ca174cf83ebe32b3198478c2211d69678845bc7", optional = true }
cubeb-pulse = { git = "https://github.com/mozilla/cubeb-pulse-rs", rev="8ff972c8e2ec1782ff262ac4071c0415e69b1367", optional = true, features=["pulse-dlopen"] }
cubeb-sys = { version = "0.12.0", optional = true, features=["gecko-in-tree"] }
audioipc2-client = { git = "https://github.com/mozilla/audioipc", rev = "409e11f8de6288e9ddfe269654523735302e59e6", optional = true }
@@ -72,15 +72,15 @@ origin-trials-ffi = { path = "../../../../dom/origin-trials/ffi" }
jog = { path = "../../../components/glean/bindings/jog" }
dap_ffi = { path = "../../../components/telemetry/dap/ffi" }
data-encoding-ffi = { path = "../../../../dom/fs/parent/rust/data-encoding-ffi" }
-uniffi-example-arithmetic = { git = "https://github.com/mozilla/uniffi-rs.git", rev = "d52c5460ae42ecad1e73a5b394ac96d48f4769de", optional = true }
-uniffi-example-geometry = { git = "https://github.com/mozilla/uniffi-rs.git", rev = "d52c5460ae42ecad1e73a5b394ac96d48f4769de", optional = true }
-uniffi-example-rondpoint = { git = "https://github.com/mozilla/uniffi-rs.git", rev = "d52c5460ae42ecad1e73a5b394ac96d48f4769de", optional = true }
-uniffi-example-sprites = { git = "https://github.com/mozilla/uniffi-rs.git", rev = "d52c5460ae42ecad1e73a5b394ac96d48f4769de", optional = true }
-uniffi-example-todolist = { git = "https://github.com/mozilla/uniffi-rs.git", rev = "d52c5460ae42ecad1e73a5b394ac96d48f4769de", optional = true }
-uniffi-example-custom-types = { path = "../../../components/uniffi-example-custom-types/", optional = true }
-uniffi-fixture-callbacks = { path = "../../../components/uniffi-fixture-callbacks/", optional = true }
-uniffi-fixture-external-types = { path = "../../../components/uniffi-fixture-external-types/", optional = true }
-uniffi-fixture-refcounts = { path = "../../../components/uniffi-fixture-refcounts/", optional = true }
+uniffi-example-arithmetic = { path = "../../../components/uniffi-fixtures/arithmetic/", optional = true }
+uniffi-example-geometry = { path = "../../../components/uniffi-fixtures/geometry/", optional = true }
+uniffi-example-rondpoint = { path = "../../../components/uniffi-fixtures/rondpoint/", optional = true }
+uniffi-example-sprites = { path = "../../../components/uniffi-fixtures/sprites/", optional = true }
+uniffi-example-todolist = { path = "../../../components/uniffi-fixtures/todolist/", optional = true }
+uniffi-example-custom-types = { path = "../../../components/uniffi-fixtures/custom-types/", optional = true }
+uniffi-fixture-callbacks = { path = "../../../components/uniffi-fixtures/callbacks/", optional = true }
+uniffi-fixture-external-types = { path = "../../../components/uniffi-fixtures/external-types/", optional = true }
+uniffi-fixture-refcounts = { path = "../../../components/uniffi-fixtures/refcounts/", optional = true }
binary_http = { path = "../../../../netwerk/protocol/http/binary_http" }
oblivious_http = { path = "../../../../netwerk/protocol/http/oblivious_http" }
mime-guess-ffi = { path = "../../../../dom/fs/parent/rust/mime-guess-ffi" }