summaryrefslogtreecommitdiffstats
path: root/toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in')
-rw-r--r--toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in23
1 files changed, 18 insertions, 5 deletions
diff --git a/toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in b/toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in
index 43552a771e..7f3bfd1cc5 100644
--- a/toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in
+++ b/toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in
@@ -5,10 +5,23 @@
include $(topsrcdir)/config/rules.mk
+# In a compile build, the moz.build stanzas produce a binary named
+# `ChannelPrefs`. We need to produce
+# `dist/bin/ChannelPrefs.framework/ChannelPrefs` for consumption by the
+# build.
+#
+# In an artifact build, we copy upstream artifacts from
+# `dist/update_framework_artifacts/ChannelPrefs-localbuild.framework`
+
ifeq (cocoa,$(MOZ_WIDGET_TOOLKIT))
libs::
- rm -rf $(DIST)/bin/ChannelPrefs.framework
-
- $(NSINSTALL) $(DIST)/bin/ChannelPrefs $(DIST)/bin/ChannelPrefs.framework
- $(NSINSTALL) $(srcdir)/Info.plist $(DIST)/bin/ChannelPrefs.framework/Resources
-endif
+ rm -rf $(FINAL_TARGET)/ChannelPrefs.framework
+ $(NSINSTALL) -D $(FINAL_TARGET)/ChannelPrefs.framework
+ifneq (,$(COMPILE_ENVIRONMENT))
+ $(NSINSTALL) $(FINAL_TARGET)/ChannelPrefs $(FINAL_TARGET)/ChannelPrefs.framework
+endif # COMPILE_ENVIRONMENT
+ifneq (,$(MOZ_ARTIFACT_BUILDS))
+ $(NSINSTALL) $(DIST)/update_framework_artifacts/ChannelPrefs-localbuild.framework/ChannelPrefs $(FINAL_TARGET)/ChannelPrefs.framework
+endif # MOZ_ARTIFACT_BUILDS
+ $(NSINSTALL) $(srcdir)/Info.plist $(FINAL_TARGET)/ChannelPrefs.framework/Resources
+endif # MOZ_WIDGET_TOOLKIT