summaryrefslogtreecommitdiffstats
path: root/toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in')
-rw-r--r--toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in b/toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in
new file mode 100644
index 0000000000..43552a771e
--- /dev/null
+++ b/toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in
@@ -0,0 +1,14 @@
+# vim:set ts=8 sw=8 sts=8 noet:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include $(topsrcdir)/config/rules.mk
+
+ifeq (cocoa,$(MOZ_WIDGET_TOOLKIT))
+libs::
+ rm -rf $(DIST)/bin/ChannelPrefs.framework
+
+ $(NSINSTALL) $(DIST)/bin/ChannelPrefs $(DIST)/bin/ChannelPrefs.framework
+ $(NSINSTALL) $(srcdir)/Info.plist $(DIST)/bin/ChannelPrefs.framework/Resources
+endif