summaryrefslogtreecommitdiffstats
path: root/tools/lint/black.yml
diff options
context:
space:
mode:
Diffstat (limited to 'tools/lint/black.yml')
-rw-r--r--tools/lint/black.yml19
1 files changed, 19 insertions, 0 deletions
diff --git a/tools/lint/black.yml b/tools/lint/black.yml
new file mode 100644
index 0000000000..c182f9939b
--- /dev/null
+++ b/tools/lint/black.yml
@@ -0,0 +1,19 @@
+---
+black:
+ description: Reformat python
+ exclude:
+ - gfx/harfbuzz/src/meson.build
+ - '**/*.mako.py'
+ - python/mozbuild/mozbuild/test/frontend/data/reader-error-syntax/moz.build
+ - testing/mozharness/configs/test/test_malformed.py
+ - testing/web-platform/tests
+ extensions:
+ - build
+ - configure
+ - mozbuild
+ - py
+ support-files:
+ - 'tools/lint/python/**'
+ type: external
+ payload: python.black:lint
+ setup: python.black:setup