summaryrefslogtreecommitdiffstats
path: root/tools/lint/ruff.yml
diff options
context:
space:
mode:
Diffstat (limited to 'tools/lint/ruff.yml')
-rw-r--r--tools/lint/ruff.yml17
1 files changed, 17 insertions, 0 deletions
diff --git a/tools/lint/ruff.yml b/tools/lint/ruff.yml
new file mode 100644
index 0000000000..59ae2a1350
--- /dev/null
+++ b/tools/lint/ruff.yml
@@ -0,0 +1,17 @@
+---
+ruff:
+ description: An extremely fast Python linter, written in Rust
+ # Excludes should be added to topsrcdir/pyproject.toml
+ exclude: []
+ # The configure option is used by the build system
+ extensions: ["configure", "py"]
+ support-files:
+ - "**/.ruff.toml"
+ - "**/ruff.toml"
+ - "**/pyproject.toml"
+ - "tools/lint/python/ruff.py"
+ # Rules that should result in warnings rather than errors.
+ warning-rules: [PLR, PLW]
+ type: external
+ payload: python.ruff:lint
+ setup: python.ruff:setup