summaryrefslogtreecommitdiffstats
path: root/xpcom/rust/malloc_size_of_derive/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'xpcom/rust/malloc_size_of_derive/Cargo.toml')
-rw-r--r--xpcom/rust/malloc_size_of_derive/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/xpcom/rust/malloc_size_of_derive/Cargo.toml b/xpcom/rust/malloc_size_of_derive/Cargo.toml
new file mode 100644
index 0000000000..cd37a9da1f
--- /dev/null
+++ b/xpcom/rust/malloc_size_of_derive/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "malloc_size_of_derive"
+version = "0.1.3"
+authors = ["The Servo Project Developers"]
+license = "MIT/Apache-2.0"
+description = "Crate for Firefox memory reporting, not intended for external use"
+
+[lib]
+path = "lib.rs"
+proc-macro = true
+
+[dependencies]
+proc-macro2 = "1"
+syn = { version = "2", features = ["parsing"] }
+synstructure = "0.13"