summaryrefslogtreecommitdiffstats
path: root/carl9170fw/minifw/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-30 16:44:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-30 16:44:52 +0000
commit1ae1ce35210e35559848b88ecd07206cdffd5f94 (patch)
treed0bfb00539f99b9026d387607ad594f507383bf3 /carl9170fw/minifw/CMakeLists.txt
parentAdding upstream version 20230625. (diff)
downloadfirmware-nonfree-upstream.tar.xz
firmware-nonfree-upstream.zip
Adding upstream version 20240709.upstream/20240709upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--carl9170fw/minifw/CMakeLists.txt20
1 files changed, 0 insertions, 20 deletions
diff --git a/carl9170fw/minifw/CMakeLists.txt b/carl9170fw/minifw/CMakeLists.txt
deleted file mode 100644
index adf5e08..0000000
--- a/carl9170fw/minifw/CMakeLists.txt
+++ /dev/null
@@ -1,20 +0,0 @@
-cmake_minimum_required(VERSION 2.8)
-
-project(miniboot.fw)
-
-include("../extra/sh-elf-linux.cmake")
-include("../config.cmake")
-
-set(miniboot_src miniboot.S)
-set_source_files_properties(miniboot.S PROPERTIES LANGUAGE C)
-
-add_executable(miniboot.elf miniboot.S)
-
-set_target_properties(miniboot.elf PROPERTIES LINKER_LANGUAGE C)
-
-set_target_properties(miniboot.elf PROPERTIES LINK_FLAGS "-Tminiboot.lds")
-
-add_custom_target(
- miniboot.fw ALL
- ${OBJCOPY} --strip-unneeded -O binary -R .sram -R .eeprom -R .fwdsc miniboot.elf miniboot.fw
- DEPENDS miniboot.elf)