summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile29
1 files changed, 27 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 50a4c29..ac43c97 100644
--- a/Makefile
+++ b/Makefile
@@ -6,11 +6,33 @@ FIRMWAREDIR = /lib/firmware
all:
check:
- @./check_whence.py
+ @if ! command -v pre-commit >/dev/null; then \
+ echo "Install pre-commit to check files"; \
+ exit 1; \
+ fi
+ @pre-commit run --all-files
+
+dist:
+ @mkdir -p release dist
+ ./copy-firmware.sh release
+ @TARGET=linux-firmware_`git describe`.tar.gz; \
+ cd release && tar -czf ../dist/$${TARGET} *; \
+ echo "Created dist/$${TARGET}"
+ @rm -rf release
+
+deb:
+ ./build_packages.py --deb
+
+rpm:
+ ./build_packages.py --rpm
install:
install -d $(DESTDIR)$(FIRMWAREDIR)
- ./copy-firmware.sh $(DESTDIR)$(FIRMWAREDIR)
+ ./copy-firmware.sh $(COPYOPTS) $(DESTDIR)$(FIRMWAREDIR)
+
+install-nodedup:
+ install -d $(DESTDIR)$(FIRMWAREDIR)
+ ./copy-firmware.sh --ignore-duplicates $(DESTDIR)$(FIRMWAREDIR)
install-xz:
install -d $(DESTDIR)$(FIRMWAREDIR)
@@ -19,3 +41,6 @@ install-xz:
install-zst:
install -d $(DESTDIR)$(FIRMWAREDIR)
./copy-firmware.sh --zstd $(DESTDIR)$(FIRMWAREDIR)
+
+clean:
+ rm -rf release dist