summaryrefslogtreecommitdiffstats
path: root/av7110/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'av7110/Makefile')
-rw-r--r--av7110/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/av7110/Makefile b/av7110/Makefile
new file mode 100644
index 0000000..a2776fe
--- /dev/null
+++ b/av7110/Makefile
@@ -0,0 +1,11 @@
+CC = arm-linux-gnueabi-gcc
+LD = arm-linux-gnueabi-ld
+OBJCOPY = arm-linux-gnueabi-objcopy
+
+bootcode.bin: Boot.S
+ $(CC) -mbig-endian -c Boot.S
+ $(LD) -Ttext 0x2c000000 -EB -o Boot Boot.o
+ $(OBJCOPY) -Obinary Boot bootcode.bin
+
+clean:
+ rm -f Boot.o Boot bootcode.bin