summaryrefslogtreecommitdiffstats
path: root/carl9170fw/tools/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--carl9170fw/tools/src/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/carl9170fw/tools/src/CMakeLists.txt b/carl9170fw/tools/src/CMakeLists.txt
new file mode 100644
index 0000000..3cd31fd
--- /dev/null
+++ b/carl9170fw/tools/src/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(tools)
+
+add_custom_target(wol ALL COMMAND gcc wol.c -o wol)
+
+set(tools fwinfo miniboot checksum eeprom_fix)
+
+foreach(tool ${tools})
+ add_executable( ${tool} ${tool}.c )
+ add_definitions("-std=gnu99 -Wall -Wextra -Wshadow")
+ target_link_libraries( ${tool} carlfw )
+endforeach()