summaryrefslogtreecommitdiffstats
path: root/keyspan_pda/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--keyspan_pda/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/keyspan_pda/Makefile b/keyspan_pda/Makefile
new file mode 100644
index 0000000..fc37ea4
--- /dev/null
+++ b/keyspan_pda/Makefile
@@ -0,0 +1,12 @@
+CC = gcc
+IHEX2FW = ihex2fw
+
+all: keyspan_pda.fw xircom_pgs.fw
+
+%.fw: %.S
+ $(CC) -x assembler-with-cpp -P -E -o $*.asm $<
+ as31 -l $*.asm
+ $(IHEX2FW) $*.hex $@
+
+clean:
+ rm -f *.asm *.fw *.hex *.lst *.obj