summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-05 13:14:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-05 13:14:37 +0000
commitfd3b2704efc2b206784615c1a23eb25501842259 (patch)
tree61ba3a8af2a0ae2ac9ec362bbf18b038f5dc0448 /Makefile.am
parentInitial commit. (diff)
downloadflac-fd3b2704efc2b206784615c1a23eb25501842259.tar.xz
flac-fd3b2704efc2b206784615c1a23eb25501842259.zip
Adding upstream version 1.4.3+ds.upstream/1.4.3+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am61
1 files changed, 61 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..3bb523e
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,61 @@
+# FLAC - Free Lossless Audio Codec
+# Copyright (C) 2001-2009 Josh Coalson
+# Copyright (C) 2011-2023 Xiph.Org Foundation
+#
+# This file is part the FLAC project. FLAC is comprised of several
+# components distributed under different licenses. The codec libraries
+# are distributed under Xiph.Org's BSD-like license (see the file
+# COPYING.Xiph in this distribution). All other programs, libraries, and
+# plugins are distributed under the GPL (see COPYING.GPL). The documentation
+# is distributed under the Gnu FDL (see COPYING.FDL). Each file in the
+# FLAC distribution contains at the top the terms under which it may be
+# distributed.
+#
+# Since this particular file is relevant to all components of FLAC,
+# it may be distributed under the Xiph.Org license, which is the least
+# restrictive of those mentioned above. See the file COPYING.Xiph in this
+# distribution.
+
+#
+# automake provides the following useful targets:
+#
+# all: build all programs and libraries using the current
+# configuration (set by configure)
+#
+# check: build and run all self-tests
+#
+# clean: remove everything except what's required to build everything
+#
+# distclean: remove everything except what goes in the distribution
+#
+
+ACLOCAL_AMFLAGS = -I m4
+
+SUBDIRS = doc include m4 man src test microbench oss-fuzz
+
+if EXAMPLES
+SUBDIRS += examples
+endif
+
+EXTRA_DIST = \
+ CMakeLists.txt \
+ config.cmake.h.in \
+ flac-config.cmake.in \
+ cmake/CheckA64NEON.c.in \
+ cmake/CheckA64NEON.cmake \
+ cmake/CheckCPUArch.c.in \
+ cmake/CheckCPUArch.cmake \
+ cmake/FindOgg.cmake \
+ cmake/UseSystemExtensions.cmake \
+ CHANGELOG.md \
+ COPYING.FDL \
+ COPYING.GPL \
+ COPYING.LGPL \
+ COPYING.Xiph \
+ README.md \
+ autogen.sh \
+ config.rpath \
+ depcomp \
+ ltmain.sh
+
+CLEANFILES = *~