summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-05 13:14:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-05 13:14:37 +0000
commit2a077a547a3b62221203e0147927fd302fb18171 (patch)
tree14ddedaba14d303124ee217b56288334955cd618 /debian/rules
parentAdding upstream version 1.4.3+ds. (diff)
downloadflac-debian.tar.xz
flac-debian.zip
Adding debian version 1.4.3+ds-2.1.debian/1.4.3+ds-2.1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules33
1 files changed, 33 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..77f7075
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,33 @@
+#!/usr/bin/make -f
+
+export DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --disable-rpath \
+ --disable-xmms-plugin \
+ $(OPTFLAGS) \
+ --enable-static \
+ --disable-silent-rules
+
+override_dh_auto_build-indep:
+ dh_auto_build -i -- -C doc
+
+override_dh_auto_install-indep:
+ dh_auto_install -i -- -C doc
+
+execute_after_dh_auto_install-arch:
+ mkdir -p debian/tmp/usr/share/man
+
+override_dh_auto_test-arch:
+ # drop (fake)root privileges,
+ # but still skip running test suite
+ # as it is *exhaustive*
+ env -u LD_PRELOAD dh_auto_test -a --no-act
+
+override_dh_auto_test-indep: