summaryrefslogtreecommitdiffstats
path: root/src/metaflac/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-05 13:14:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-05 13:14:37 +0000
commitfd3b2704efc2b206784615c1a23eb25501842259 (patch)
tree61ba3a8af2a0ae2ac9ec362bbf18b038f5dc0448 /src/metaflac/Makefile.am
parentInitial commit. (diff)
downloadflac-fd3b2704efc2b206784615c1a23eb25501842259.tar.xz
flac-fd3b2704efc2b206784615c1a23eb25501842259.zip
Adding upstream version 1.4.3+ds.upstream/1.4.3+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/metaflac/Makefile.am')
-rw-r--r--src/metaflac/Makefile.am65
1 files changed, 65 insertions, 0 deletions
diff --git a/src/metaflac/Makefile.am b/src/metaflac/Makefile.am
new file mode 100644
index 0000000..8c212ff
--- /dev/null
+++ b/src/metaflac/Makefile.am
@@ -0,0 +1,65 @@
+# metaflac - Command-line FLAC metadata editor
+# Copyright (C) 2000-2009 Josh Coalson
+# Copyright (C) 2011-2023 Xiph.Org Foundation
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+if OS_IS_WINDOWS
+win_utf8_lib = $(top_builddir)/src/share/win_utf8_io/libwin_utf8_io.la
+if HAVE_WINDRES
+metaflac_DEPENDENCIES = version.o
+windows_resource_link = -Wl,version.o
+endif
+endif
+
+bin_PROGRAMS = metaflac
+
+AM_CFLAGS = @OGG_CFLAGS@
+AM_CPPFLAGS = -I$(top_builddir) -I$(srcdir)/include -I$(top_srcdir)/include
+EXTRA_DIST = \
+ CMakeLists.txt \
+ version.rc
+
+metaflac_SOURCES = \
+ main.c \
+ operations.c \
+ operations_shorthand_cuesheet.c \
+ operations_shorthand_picture.c \
+ operations_shorthand_seektable.c \
+ operations_shorthand_streaminfo.c \
+ operations_shorthand_vorbiscomment.c \
+ options.c \
+ usage.c \
+ utils.c \
+ operations.h \
+ operations_shorthand.h \
+ options.h \
+ usage.h \
+ utils.h
+metaflac_LDFLAGS = $(AM_LDFLAGS) $(windows_resource_link)
+
+metaflac_LDADD = \
+ $(top_builddir)/src/share/grabbag/libgrabbag.la \
+ $(top_builddir)/src/share/replaygain_analysis/libreplaygain_analysis.la \
+ $(top_builddir)/src/share/getopt/libgetopt.la \
+ $(top_builddir)/src/share/utf8/libutf8.la \
+ $(top_builddir)/src/libFLAC/libFLAC.la \
+ $(win_utf8_lib) \
+ @LTLIBICONV@
+
+CLEANFILES = metaflac.exe
+
+.rc.o:
+ $(RC) $(AM_CPPFLAGS) $< $@