summaryrefslogtreecommitdiffstats
path: root/src/share/getopt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/share/getopt/CMakeLists.txt')
-rw-r--r--src/share/getopt/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/share/getopt/CMakeLists.txt b/src/share/getopt/CMakeLists.txt
new file mode 100644
index 0000000..d905615
--- /dev/null
+++ b/src/share/getopt/CMakeLists.txt
@@ -0,0 +1,13 @@
+check_include_file("string.h" HAVE_STRING_H)
+
+if(NOT WIN32)
+ find_package(Intl)
+endif()
+
+add_library(getopt STATIC getopt.c getopt1.c)
+
+if(Intl_FOUND)
+ target_include_directories(getopt PRIVATE ${Intl_INCLUDE_DIRS})
+ target_link_libraries(getopt PUBLIC ${Intl_LIBRARIES})
+ target_compile_definitions(getopt PRIVATE HAVE_LIBINTL_H)
+endif()