summaryrefslogtreecommitdiffstats
path: root/src/test_streams/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/test_streams/Makefile.am')
-rw-r--r--src/test_streams/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/test_streams/Makefile.am b/src/test_streams/Makefile.am
new file mode 100644
index 0000000..9aa4b02
--- /dev/null
+++ b/src/test_streams/Makefile.am
@@ -0,0 +1,29 @@
+# test_streams - Simple test pattern generator
+# Copyright (C) 2000-2009 Josh Coalson
+# Copyright (C) 2011-2023 Xiph.Org Foundation
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+EXTRA_DIST = \
+ CMakeLists.txt
+
+AM_CPPFLAGS = -I$(top_builddir) -I$(srcdir)/include -I$(top_srcdir)/include
+check_PROGRAMS = test_streams
+test_streams_SOURCES = \
+ main.c
+
+test_streams_LDADD = $(top_builddir)/src/share/grabbag/libgrabbag.la -lm
+
+CLEANFILES = test_streams.exe