summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..ef5dd8d
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,35 @@
+#
+# force-ip-protocol
+# Copyright (C) 2023 Thorsten Alteholz
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+AC_INIT([force-ip-protocol], [0.2.0], [thorsten@alteholz.dev])
+
+AM_INIT_AUTOMAKE
+LT_INIT()
+
+AC_CONFIG_MACRO_DIRS([m4])
+AC_CONFIG_HEADERS([config.h:config.h.in])
+AC_CHECK_HEADERS([sys/socket.h])
+AC_CHECK_HEADERS([netdb.h])
+
+
+AC_PROG_CC
+AC_CONFIG_FILES([Makefile])
+
+AC_ENABLE_SHARED
+AC_DISABLE_STATIC
+
+AC_OUTPUT