summaryrefslogtreecommitdiffstats
path: root/scripts/docker/rocky8
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-26 10:41:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-26 10:41:52 +0000
commitde8bf9112695763664912e340b265fa898188460 (patch)
tree9bcd5f8d45fc3b81174d3de8abfd573b68e9d7f6 /scripts/docker/rocky8
parentAdding debian version 3.2.3+dfsg-2. (diff)
downloadfreeradius-de8bf9112695763664912e340b265fa898188460.tar.xz
freeradius-de8bf9112695763664912e340b265fa898188460.zip
Merging upstream version 3.2.5+dfsg.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripts/docker/rocky8')
-rw-r--r--scripts/docker/rocky8/Dockerfile108
-rwxr-xr-xscripts/docker/rocky8/docker-entrypoint.sh24
2 files changed, 0 insertions, 132 deletions
diff --git a/scripts/docker/rocky8/Dockerfile b/scripts/docker/rocky8/Dockerfile
deleted file mode 100644
index ca821a3..0000000
--- a/scripts/docker/rocky8/Dockerfile
+++ /dev/null
@@ -1,108 +0,0 @@
-ARG from=rockylinux/rockylinux:8
-FROM ${from} as build
-
-RUN rpmkeys --import /etc/pki/rpm-gpg/RPM-GPG-KEY-rockyofficial
-
-#
-# Install build tools
-#
-RUN yum groupinstall -y "Development Tools"
-RUN yum install -y rpmdevtools openssl dnf-utils
-
-#
-# Create build directory
-#
-RUN mkdir -p /usr/local/src/repositories
-WORKDIR /usr/local/src/repositories
-
-#
-# Shallow clone the FreeRADIUS source
-#
-ARG source=https://github.com/FreeRADIUS/freeradius-server.git
-ARG release=v3.2.x
-
-RUN git clone --depth 1 --single-branch --branch ${release} ${source}
-WORKDIR freeradius-server
-
-#
-# Other requirements
-#
-
-# Use LTB's openldap packages intead of the distribution version to avoid linking against NSS
-RUN echo $'[ltb-project]\n\
-name=LTB project packages\n\
-baseurl=https://ltb-project.org/rpm/$releasever/$basearch\n\
-enabled=1\n\
-gpgcheck=1\n\
-gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-LTB-project'\
-> /etc/yum.repos.d/ltb-project.repo
-RUN rpm --import https://ltb-project.org/lib/RPM-GPG-KEY-LTB-project
-
-# EPEL repository for freetds and hiredis
-RUN yum install -y https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm
-
-RUN yum config-manager --enable powertools
-# Currently needed for hiredis-devel
-RUN yum config-manager --enable epel-testing
-
-#
-# Install build dependencies
-#
-RUN [ -e redhat/freeradius.spec ] && yum-builddep -y redhat/freeradius.spec
-
-#
-# Create RPM build environment
-#
-ENV BUILDDIR=/root/rpmbuild
-RUN rpmdev-setuptree
-
-RUN ./configure
-RUN make freeradius-server-$(cat VERSION).tar.bz2
-RUN cp freeradius-server-$(cat VERSION).tar.bz2 $BUILDDIR/SOURCES/
-RUN cp -r redhat/* $BUILDDIR/SOURCES/
-RUN cp -r redhat/freeradius.spec $BUILDDIR/SPECS/
-WORKDIR $BUILDDIR
-
-#
-# Build the server
-#
-ENV QA_RPATHS=0x0003
-RUN rpmbuild -bb --define '_release $release' "$BUILDDIR/SPECS/freeradius.spec"
-
-RUN mkdir /root/rpms
-RUN mv $BUILDDIR/RPMS/*/*.rpm /root/rpms/
-
-#
-# Clean environment and run the server
-#
-FROM ${from}
-COPY --from=build /root/rpms /tmp/
-
-# Use LTB's openldap packages intead of the distribution version to avoid linking against NSS
-RUN echo $'[ltb-project]\n\
-name=LTB project packages\n\
-baseurl=https://ltb-project.org/rpm/$releasever/$basearch\n\
-enabled=1\n\
-gpgcheck=1\n\
-gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-LTB-project'\
-> /etc/yum.repos.d/ltb-project.repo \
- && rpm --import https://ltb-project.org/lib/RPM-GPG-KEY-LTB-project \
- \
-# EPEL repository for freetds and hiredis
- && yum install -y https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm \
- && yum install -y dnf-utils \
- && yum config-manager --enable epel-testing
-
-ARG radiusd_uid=95
-ARG radiusd_gid=95
-
-RUN groupadd -g ${radiusd_gid} -r radiusd \
- && useradd -u ${radiusd_uid} -g radiusd -r -M -d /home/radiusd -s /sbin/nologin radiusd \
- && yum install -y /tmp/*.rpm
-
-COPY docker-entrypoint.sh /
-RUN chmod +x /docker-entrypoint.sh
-
-EXPOSE 1812/udp 1813/udp
-ENTRYPOINT ["/docker-entrypoint.sh"]
-CMD ["radiusd"]
diff --git a/scripts/docker/rocky8/docker-entrypoint.sh b/scripts/docker/rocky8/docker-entrypoint.sh
deleted file mode 100755
index 900ad6b..0000000
--- a/scripts/docker/rocky8/docker-entrypoint.sh
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-set -e
-
-# this if will check if the first argument is a flag
-# but only works if all arguments require a hyphenated flag
-# -v; -SL; -f arg; etc will work, but not arg1 arg2
-if [ "$#" -eq 0 ] || [ "${1#-}" != "$1" ]; then
- set -- radiusd "$@"
-fi
-
-# check for the expected command
-if [ "$1" = 'radiusd' ]; then
- shift
- exec radiusd -f "$@"
-fi
-
-# debian people are likely to call "freeradius" as well, so allow that
-if [ "$1" = 'freeradius' ]; then
- shift
- exec radiusd -f "$@"
-fi
-
-# else default to run whatever the user wanted like "bash" or "sh"
-exec "$@"