summaryrefslogtreecommitdiffstats
path: root/debian/patches/fix-parallel-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/fix-parallel-build.patch')
-rw-r--r--debian/patches/fix-parallel-build.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/patches/fix-parallel-build.patch b/debian/patches/fix-parallel-build.patch
new file mode 100644
index 0000000..1e0bf63
--- /dev/null
+++ b/debian/patches/fix-parallel-build.patch
@@ -0,0 +1,16 @@
+Description: Use system libtool to install radsecret
+ ${PROGRAM_INSTALL} points to a local jlibtool instance, which might
+ not compiled be yet with parallel building. ${INSTALL} is used in
+ all other .mk files
+Forwarded: https://github.com/FreeRADIUS/freeradius-server/issues/5365
+Author: Bernhard Schmidt <berni@debian.org>
+Last-Update: 2024-07-10
+
+--- a/src/main/radsecret.mk
++++ b/src/main/radsecret.mk
+@@ -2,4 +2,4 @@
+
+ $(R)/$(bindir)/radsecret: ${top_srcdir}/src/main/radsecret
+ @$(ECHO) INSTALL radsecret
+- $(Q)${PROGRAM_INSTALL} -c -m 755 $< $@
++ $(Q)${INSTALL} -c -m 755 $< $@