summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/fix-parallel-build.patch16
-rw-r--r--debian/patches/series1
2 files changed, 17 insertions, 0 deletions
diff --git a/debian/patches/fix-parallel-build.patch b/debian/patches/fix-parallel-build.patch
new file mode 100644
index 0000000..1e0bf63
--- /dev/null
+++ b/debian/patches/fix-parallel-build.patch
@@ -0,0 +1,16 @@
+Description: Use system libtool to install radsecret
+ ${PROGRAM_INSTALL} points to a local jlibtool instance, which might
+ not compiled be yet with parallel building. ${INSTALL} is used in
+ all other .mk files
+Forwarded: https://github.com/FreeRADIUS/freeradius-server/issues/5365
+Author: Bernhard Schmidt <berni@debian.org>
+Last-Update: 2024-07-10
+
+--- a/src/main/radsecret.mk
++++ b/src/main/radsecret.mk
+@@ -2,4 +2,4 @@
+
+ $(R)/$(bindir)/radsecret: ${top_srcdir}/src/main/radsecret
+ @$(ECHO) INSTALL radsecret
+- $(Q)${PROGRAM_INSTALL} -c -m 755 $< $@
++ $(Q)${INSTALL} -c -m 755 $< $@
diff --git a/debian/patches/series b/debian/patches/series
index 816e30a..5dfbaa2 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,3 +5,4 @@ debian-local/0001-Rename-radius-to-freeradius.patch
debian-local/0010-version.c-disable-openssl-version-check.patch
dont-install-tests.diff
snakeoil-certs.diff
+fix-parallel-build.patch