summaryrefslogtreecommitdiffstats
path: root/raddb/all.mk
diff options
context:
space:
mode:
Diffstat (limited to 'raddb/all.mk')
-rw-r--r--raddb/all.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/raddb/all.mk b/raddb/all.mk
index a7f4f14..6ab8c78 100644
--- a/raddb/all.mk
+++ b/raddb/all.mk
@@ -13,11 +13,15 @@ DEFAULT_MODULES := always attr_filter chap date \
mschap ntlm_auth pap passwd preprocess radutmp realm \
replicate soh sradutmp totp unix unpack utf8
+ifneq "$(OPENSSL_LIBS)" ""
+DEFAULT_MODULE += dpsk
+endif
+
LOCAL_MODULES := $(addprefix raddb/mods-enabled/,$(DEFAULT_MODULES))
LOCAL_CERT_FILES := Makefile README.md xpextensions \
ca.cnf server.cnf inner-server.cnf \
- client.cnf bootstrap
+ client.cnf realms/README.md bootstrap
#
# We don't create the installed certs if we're building a package,
@@ -32,7 +36,7 @@ endif
LEGACY_LINKS := $(addprefix $(R)$(raddbdir)/,users huntgroups hints)
-RADDB_DIRS := certs mods-available mods-enabled policy.d \
+RADDB_DIRS := certs certs/realms mods-available mods-enabled policy.d \
sites-available sites-enabled \
$(patsubst raddb/%,%,$(shell find raddb/mods-config -type d -print))