summaryrefslogtreecommitdiffstats
path: root/scripts/crossbuild/docker/centos8
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--scripts/crossbuild/docker/rocky8/Dockerfile (renamed from scripts/crossbuild/docker/centos8/Dockerfile)35
1 files changed, 28 insertions, 7 deletions
diff --git a/scripts/crossbuild/docker/centos8/Dockerfile b/scripts/crossbuild/docker/rocky8/Dockerfile
index bd856af..ba7fc56 100644
--- a/scripts/crossbuild/docker/centos8/Dockerfile
+++ b/scripts/crossbuild/docker/rocky8/Dockerfile
@@ -1,27 +1,38 @@
-FROM centos:centos8
+# Auto generated for rocky8
+# from scripts/crossbuild/m4/Dockerfile.rpm.m4
+#
+# Rebuild this file with `make crossbuild.rocky8.regen`
+#
+ARG from=rockylinux/rockylinux:8
+FROM ${from} as build
#
# Install devtools like make and git and the EPEL
# repository for freetds and hiredis
#
RUN yum update -y
-RUN yum install -y rpmdevtools openssl epel-release git yum-utils rsync dnf-plugins-core
-RUN dnf config-manager --set-enabled powertools
+RUN yum install -y rpmdevtools openssl epel-release git procps yum-utils \
+ rsync dnf-plugins-core
+
+
+RUN yum config-manager --set-enabled powertools
#
# Install GCC that has the requisite support for C11 keywords and atomics
#
RUN yum install -y gcc-toolset-9
+
#
# Documentation build dependecies
#
+
# - doxygen & JSON.pm
RUN yum install -y doxygen graphviz perl-JSON
# - antora (npm needed)
-RUN curl -sL https://rpm.nodesource.com/setup_10.x | bash -
+RUN curl -sL https://rpm.nodesource.com/setup_20.x | bash -
RUN yum install -y nodejs
-RUN npm i -g @antora/cli@2.1 @antora/site-generator-default@2.1
+RUN npm i -g @antora/cli@3.1.7 @antora/site-generator-default@3.1.7
# - pandoc
RUN curl -o - -L $(curl -s https://api.github.com/repos/jgm/pandoc/releases/latest | grep "browser_download_url.*tar.gz" | cut -d '"' -f 4) | tar xzvf - -C /tmp/
RUN mv /tmp/pandoc-*/bin/* /usr/local/bin
@@ -56,14 +67,19 @@ RUN git clone --depth 1 --no-single-branch ${source}
#
# Install build dependencies for all branches from v3 onwards
+# Nodesource has issues (no SRPMS in some repos) and is not needed here
+# CentOS/RHEL 7 do not support "-D" for yum-builddep so do that separately below if needed
#
WORKDIR freeradius-server
RUN for i in $(git for-each-ref --format='%(refname:short)' refs/remotes/origin 2>/dev/null | sed -e 's#origin/##' | egrep "^(v[3-9]*\.[0-9x]*\.x|master)$");\
do \
git checkout $i; \
- [ -e redhat/freeradius.spec ] && yum-builddep -y redhat/freeradius.spec; \
+ [ -e redhat/freeradius.spec ] && yum-builddep -D "_with_rlm_yubikey 1" -y redhat/freeradius.spec; \
done
+
+RUN yum install -y libyubikey-devel
+
#
# Which is required by fixture setup utilities
#
@@ -75,7 +91,12 @@ RUN yum install -y which
RUN yum install -y libnl3-devel
#
+# We test with TLS1.1, but that is disabled by default on some
+# newer systems.
+#
+RUN update-crypto-policies --set LEGACY
+
+#
# Create the RPM build tree
#
-ENV BUILDDIR=/root/rpmbuild
RUN rpmdev-setuptree