summaryrefslogtreecommitdiffstats
path: root/channels/rdpei/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'channels/rdpei/CMakeLists.txt')
-rw-r--r--channels/rdpei/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/channels/rdpei/CMakeLists.txt b/channels/rdpei/CMakeLists.txt
new file mode 100644
index 0000000..a93af67
--- /dev/null
+++ b/channels/rdpei/CMakeLists.txt
@@ -0,0 +1,26 @@
+# FreeRDP: A Remote Desktop Protocol Implementation
+# FreeRDP cmake build script
+#
+# Copyright 2012 Marc-Andre Moreau <marcandre.moreau@gmail.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+define_channel("rdpei")
+
+if(WITH_CLIENT_CHANNELS)
+ add_channel_client(${MODULE_PREFIX} ${CHANNEL_NAME})
+endif()
+
+if(WITH_SERVER_CHANNELS)
+ add_channel_server(${MODULE_PREFIX} ${CHANNEL_NAME})
+endif() \ No newline at end of file