summaryrefslogtreecommitdiffstats
path: root/client/Sample
diff options
context:
space:
mode:
Diffstat (limited to 'client/Sample')
-rw-r--r--client/Sample/CMakeLists.txt77
-rw-r--r--client/Sample/ModuleOptions.cmake4
-rw-r--r--client/Sample/tf_channels.c79
-rw-r--r--client/Sample/tf_channels.h33
-rw-r--r--client/Sample/tf_freerdp.c411
-rw-r--r--client/Sample/tf_freerdp.h37
6 files changed, 641 insertions, 0 deletions
diff --git a/client/Sample/CMakeLists.txt b/client/Sample/CMakeLists.txt
new file mode 100644
index 0000000..db4e947
--- /dev/null
+++ b/client/Sample/CMakeLists.txt
@@ -0,0 +1,77 @@
+# FreeRDP: A Remote Desktop Protocol Implementation
+# FreeRDP Sample UI cmake build script
+#
+# Copyright 2012 Marc-Andre Moreau <marcandre.moreau@gmail.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+cmake_minimum_required(VERSION 3.13)
+
+if(POLICY CMP0091)
+ cmake_policy(SET CMP0091 NEW)
+endif()
+if (NOT FREERDP_DEFAULT_PROJECT_VERSION)
+ set(FREERDP_DEFAULT_PROJECT_VERSION "1.0.0.0")
+endif()
+
+project(sfreerdp
+ LANGUAGES C
+ VERSION ${FREERDP_DEFAULT_PROJECT_VERSION}
+)
+
+message("project ${PROJECT_NAME} is using version ${PROJECT_VERSION}")
+
+set(CMAKE_C_STANDARD 11)
+set(CMAKE_C_STANDARD_REQUIRED ON)
+set(CMAKE_C_EXTENSIONS ON)
+
+list(APPEND CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/../../cmake/)
+include(CommonConfigOptions)
+
+include(ConfigureFreeRDP)
+
+set(SRCS
+ tf_channels.c
+ tf_channels.h
+ tf_freerdp.h
+ tf_freerdp.c)
+
+# On windows create dll version information.
+# Vendor, product and year are already set in top level CMakeLists.txt
+if (WIN32)
+ set (RC_VERSION_MAJOR ${FREERDP_VERSION_MAJOR})
+ set (RC_VERSION_MINOR ${FREERDP_VERSION_MINOR})
+ set (RC_VERSION_BUILD ${FREERDP_VERSION_REVISION})
+ set (RC_VERSION_FILE "${PROJECT_NAME}${CMAKE_EXECUTABLE_SUFFIX}" )
+
+ configure_file(
+ ${PROJECT_SOURCE_DIR}/../../cmake/WindowsDLLVersion.rc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/version.rc
+ @ONLY)
+
+list (APPEND SRCS ${CMAKE_CURRENT_BINARY_DIR}/version.rc)
+endif()
+
+add_executable(${PROJECT_NAME} ${SRCS})
+
+set(LIBS
+ freerdp-client
+ freerdp
+ winpr
+)
+target_link_libraries(${PROJECT_NAME} PRIVATE ${LIBS})
+
+if (WITH_BINARY_VERSIONING)
+ set_target_properties(${PROJECT_NAME} PROPERTIES OUTPUT_NAME "${PROJECT_NAME}${PROJECT_VERSION_MAJOR}")
+endif()
+set_property(TARGET ${PROJECT_NAME} PROPERTY FOLDER "Client/Sample")
+install(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT client)
diff --git a/client/Sample/ModuleOptions.cmake b/client/Sample/ModuleOptions.cmake
new file mode 100644
index 0000000..d4d5a9e
--- /dev/null
+++ b/client/Sample/ModuleOptions.cmake
@@ -0,0 +1,4 @@
+
+set(FREERDP_CLIENT_NAME "sfreerdp")
+set(FREERDP_CLIENT_PLATFORM "Sample")
+set(FREERDP_CLIENT_VENDOR "FreeRDP")
diff --git a/client/Sample/tf_channels.c b/client/Sample/tf_channels.c
new file mode 100644
index 0000000..d1bfdb8
--- /dev/null
+++ b/client/Sample/tf_channels.c
@@ -0,0 +1,79 @@
+/**
+ * FreeRDP: A Remote Desktop Protocol Implementation
+ * Sample Client Channels
+ *
+ * Copyright 2018 Armin Novak <armin.novak@thincast.com>
+ * Copyright 2018 Thincast Technologies GmbH
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+#include <freerdp/config.h>
+
+#include <winpr/assert.h>
+#include <freerdp/gdi/gfx.h>
+
+#include <freerdp/client/rdpei.h>
+#include <freerdp/client/rail.h>
+#include <freerdp/client/cliprdr.h>
+#include <freerdp/client/rdpgfx.h>
+#include <freerdp/client/encomsp.h>
+
+#include "tf_channels.h"
+#include "tf_freerdp.h"
+
+static UINT tf_update_surfaces(RdpgfxClientContext* context)
+{
+ WINPR_UNUSED(context);
+ return CHANNEL_RC_OK;
+}
+
+void tf_OnChannelConnectedEventHandler(void* context, const ChannelConnectedEventArgs* e)
+{
+ tfContext* tf = (tfContext*)context;
+
+ WINPR_ASSERT(tf);
+ WINPR_ASSERT(e);
+
+ if (strcmp(e->name, RAIL_SVC_CHANNEL_NAME) == 0)
+ {
+ }
+ else if (strcmp(e->name, CLIPRDR_SVC_CHANNEL_NAME) == 0)
+ {
+ CliprdrClientContext* clip = (CliprdrClientContext*)e->pInterface;
+ WINPR_ASSERT(clip);
+ clip->custom = context;
+ }
+ else
+ freerdp_client_OnChannelConnectedEventHandler(context, e);
+}
+
+void tf_OnChannelDisconnectedEventHandler(void* context, const ChannelDisconnectedEventArgs* e)
+{
+ tfContext* tf = (tfContext*)context;
+
+ WINPR_ASSERT(tf);
+ WINPR_ASSERT(e);
+
+ if (strcmp(e->name, RAIL_SVC_CHANNEL_NAME) == 0)
+ {
+ }
+ else if (strcmp(e->name, CLIPRDR_SVC_CHANNEL_NAME) == 0)
+ {
+ CliprdrClientContext* clip = (CliprdrClientContext*)e->pInterface;
+ WINPR_ASSERT(clip);
+ clip->custom = NULL;
+ }
+ else
+ freerdp_client_OnChannelDisconnectedEventHandler(context, e);
+}
diff --git a/client/Sample/tf_channels.h b/client/Sample/tf_channels.h
new file mode 100644
index 0000000..d00a5c2
--- /dev/null
+++ b/client/Sample/tf_channels.h
@@ -0,0 +1,33 @@
+/**
+ * FreeRDP: A Remote Desktop Protocol Implementation
+ * Sample Client Channels
+ *
+ * Copyright 2018 Armin Novak <armin.novak@thincast.com>
+ * Copyright 2018 Thincast Technologies GmbH
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+#ifndef FREERDP_CLIENT_SAMPLE_CHANNELS_H
+#define FREERDP_CLIENT_SAMPLE_CHANNELS_H
+
+#include <freerdp/freerdp.h>
+#include <freerdp/client/channels.h>
+
+int tf_on_channel_connected(freerdp* instance, const char* name, void* pInterface);
+int tf_on_channel_disconnected(freerdp* instance, const char* name, void* pInterface);
+
+void tf_OnChannelConnectedEventHandler(void* context, const ChannelConnectedEventArgs* e);
+void tf_OnChannelDisconnectedEventHandler(void* context, const ChannelDisconnectedEventArgs* e);
+
+#endif /* FREERDP_CLIENT_SAMPLE_CHANNELS_H */
diff --git a/client/Sample/tf_freerdp.c b/client/Sample/tf_freerdp.c
new file mode 100644
index 0000000..2a799fc
--- /dev/null
+++ b/client/Sample/tf_freerdp.c
@@ -0,0 +1,411 @@
+/**
+ * FreeRDP: A Remote Desktop Protocol Implementation
+ * FreeRDP Test UI
+ *
+ * Copyright 2011 Marc-Andre Moreau <marcandre.moreau@gmail.com>
+ * Copyright 2016,2018 Armin Novak <armin.novak@thincast.com>
+ * Copyright 2016,2018 Thincast Technologies GmbH
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+#include <freerdp/config.h>
+
+#include <errno.h>
+#include <stdio.h>
+#include <string.h>
+
+#include <freerdp/freerdp.h>
+#include <freerdp/constants.h>
+#include <freerdp/gdi/gdi.h>
+#include <freerdp/streamdump.h>
+#include <freerdp/utils/signal.h>
+
+#include <freerdp/client/file.h>
+#include <freerdp/client/cmdline.h>
+#include <freerdp/client/cliprdr.h>
+#include <freerdp/client/channels.h>
+#include <freerdp/channels/channels.h>
+
+#include <winpr/crt.h>
+#include <winpr/assert.h>
+#include <winpr/synch.h>
+#include <freerdp/log.h>
+
+#include "tf_channels.h"
+#include "tf_freerdp.h"
+
+#define TAG CLIENT_TAG("sample")
+
+/* This function is called whenever a new frame starts.
+ * It can be used to reset invalidated areas. */
+static BOOL tf_begin_paint(rdpContext* context)
+{
+ rdpGdi* gdi = NULL;
+
+ WINPR_ASSERT(context);
+
+ gdi = context->gdi;
+ WINPR_ASSERT(gdi);
+ WINPR_ASSERT(gdi->primary);
+ WINPR_ASSERT(gdi->primary->hdc);
+ WINPR_ASSERT(gdi->primary->hdc->hwnd);
+ WINPR_ASSERT(gdi->primary->hdc->hwnd->invalid);
+ gdi->primary->hdc->hwnd->invalid->null = TRUE;
+ return TRUE;
+}
+
+/* This function is called when the library completed composing a new
+ * frame. Read out the changed areas and blit them to your output device.
+ * The image buffer will have the format specified by gdi_init
+ */
+static BOOL tf_end_paint(rdpContext* context)
+{
+ rdpGdi* gdi = NULL;
+
+ WINPR_ASSERT(context);
+
+ gdi = context->gdi;
+ WINPR_ASSERT(gdi);
+ WINPR_ASSERT(gdi->primary);
+ WINPR_ASSERT(gdi->primary->hdc);
+ WINPR_ASSERT(gdi->primary->hdc->hwnd);
+ WINPR_ASSERT(gdi->primary->hdc->hwnd->invalid);
+
+ if (gdi->primary->hdc->hwnd->invalid->null)
+ return TRUE;
+
+ return TRUE;
+}
+
+static BOOL tf_desktop_resize(rdpContext* context)
+{
+ rdpGdi* gdi = NULL;
+ rdpSettings* settings = NULL;
+
+ WINPR_ASSERT(context);
+
+ settings = context->settings;
+ WINPR_ASSERT(settings);
+
+ gdi = context->gdi;
+ return gdi_resize(gdi, freerdp_settings_get_uint32(settings, FreeRDP_DesktopWidth),
+ freerdp_settings_get_uint32(settings, FreeRDP_DesktopHeight));
+}
+
+/* This function is called to output a System BEEP */
+static BOOL tf_play_sound(rdpContext* context, const PLAY_SOUND_UPDATE* play_sound)
+{
+ /* TODO: Implement */
+ WINPR_UNUSED(context);
+ WINPR_UNUSED(play_sound);
+ return TRUE;
+}
+
+/* This function is called to update the keyboard indocator LED */
+static BOOL tf_keyboard_set_indicators(rdpContext* context, UINT16 led_flags)
+{
+ /* TODO: Set local keyboard indicator LED status */
+ WINPR_UNUSED(context);
+ WINPR_UNUSED(led_flags);
+ return TRUE;
+}
+
+/* This function is called to set the IME state */
+static BOOL tf_keyboard_set_ime_status(rdpContext* context, UINT16 imeId, UINT32 imeState,
+ UINT32 imeConvMode)
+{
+ if (!context)
+ return FALSE;
+
+ WLog_WARN(TAG,
+ "KeyboardSetImeStatus(unitId=%04" PRIx16 ", imeState=%08" PRIx32
+ ", imeConvMode=%08" PRIx32 ") ignored",
+ imeId, imeState, imeConvMode);
+ return TRUE;
+}
+
+/* Called before a connection is established.
+ * Set all configuration options to support and load channels here. */
+static BOOL tf_pre_connect(freerdp* instance)
+{
+ rdpSettings* settings = NULL;
+
+ WINPR_ASSERT(instance);
+ WINPR_ASSERT(instance->context);
+
+ settings = instance->context->settings;
+ WINPR_ASSERT(settings);
+
+ /* Optional OS identifier sent to server */
+ if (!freerdp_settings_set_uint32(settings, FreeRDP_OsMajorType, OSMAJORTYPE_UNIX))
+ return FALSE;
+ if (!freerdp_settings_set_uint32(settings, FreeRDP_OsMinorType, OSMINORTYPE_NATIVE_XSERVER))
+ return FALSE;
+ /* OrderSupport is initialized at this point.
+ * Only override it if you plan to implement custom order
+ * callbacks or deactiveate certain features. */
+ /* Register the channel listeners.
+ * They are required to set up / tear down channels if they are loaded. */
+ PubSub_SubscribeChannelConnected(instance->context->pubSub, tf_OnChannelConnectedEventHandler);
+ PubSub_SubscribeChannelDisconnected(instance->context->pubSub,
+ tf_OnChannelDisconnectedEventHandler);
+
+ /* TODO: Any code your client requires */
+ return TRUE;
+}
+
+/* Called after a RDP connection was successfully established.
+ * Settings might have changed during negociation of client / server feature
+ * support.
+ *
+ * Set up local framebuffers and paing callbacks.
+ * If required, register pointer callbacks to change the local mouse cursor
+ * when hovering over the RDP window
+ */
+static BOOL tf_post_connect(freerdp* instance)
+{
+ rdpContext* context = NULL;
+
+ if (!gdi_init(instance, PIXEL_FORMAT_XRGB32))
+ return FALSE;
+
+ context = instance->context;
+ WINPR_ASSERT(context);
+ WINPR_ASSERT(context->update);
+
+ /* With this setting we disable all graphics processing in the library.
+ *
+ * This allows low resource (client) protocol parsing.
+ */
+ if (!freerdp_settings_set_bool(context->settings, FreeRDP_DeactivateClientDecoding, TRUE))
+ return FALSE;
+
+ context->update->BeginPaint = tf_begin_paint;
+ context->update->EndPaint = tf_end_paint;
+ context->update->PlaySound = tf_play_sound;
+ context->update->DesktopResize = tf_desktop_resize;
+ context->update->SetKeyboardIndicators = tf_keyboard_set_indicators;
+ context->update->SetKeyboardImeStatus = tf_keyboard_set_ime_status;
+ return TRUE;
+}
+
+/* This function is called whether a session ends by failure or success.
+ * Clean up everything allocated by pre_connect and post_connect.
+ */
+static void tf_post_disconnect(freerdp* instance)
+{
+ tfContext* context = NULL;
+
+ if (!instance)
+ return;
+
+ if (!instance->context)
+ return;
+
+ context = (tfContext*)instance->context;
+ PubSub_UnsubscribeChannelConnected(instance->context->pubSub,
+ tf_OnChannelConnectedEventHandler);
+ PubSub_UnsubscribeChannelDisconnected(instance->context->pubSub,
+ tf_OnChannelDisconnectedEventHandler);
+ gdi_free(instance);
+ /* TODO : Clean up custom stuff */
+ WINPR_UNUSED(context);
+}
+
+/* RDP main loop.
+ * Connects RDP, loops while running and handles event and dispatch, cleans up
+ * after the connection ends. */
+static DWORD WINAPI tf_client_thread_proc(LPVOID arg)
+{
+ freerdp* instance = (freerdp*)arg;
+ DWORD nCount = 0;
+ DWORD status = 0;
+ DWORD result = 0;
+ HANDLE handles[MAXIMUM_WAIT_OBJECTS] = { 0 };
+ BOOL rc = freerdp_connect(instance);
+
+ WINPR_ASSERT(instance->context);
+ WINPR_ASSERT(instance->context->settings);
+ if (freerdp_settings_get_bool(instance->context->settings, FreeRDP_AuthenticationOnly))
+ {
+ result = freerdp_get_last_error(instance->context);
+ freerdp_abort_connect_context(instance->context);
+ WLog_ERR(TAG, "Authentication only, exit status 0x%08" PRIx32 "", result);
+ goto disconnect;
+ }
+
+ if (!rc)
+ {
+ result = freerdp_get_last_error(instance->context);
+ WLog_ERR(TAG, "connection failure 0x%08" PRIx32, result);
+ return result;
+ }
+
+ while (!freerdp_shall_disconnect_context(instance->context))
+ {
+ nCount = freerdp_get_event_handles(instance->context, handles, ARRAYSIZE(handles));
+
+ if (nCount == 0)
+ {
+ WLog_ERR(TAG, "freerdp_get_event_handles failed");
+ break;
+ }
+
+ status = WaitForMultipleObjects(nCount, handles, FALSE, 100);
+
+ if (status == WAIT_FAILED)
+ {
+ WLog_ERR(TAG, "WaitForMultipleObjects failed with %" PRIu32 "", status);
+ break;
+ }
+
+ if (!freerdp_check_event_handles(instance->context))
+ {
+ if (freerdp_get_last_error(instance->context) == FREERDP_ERROR_SUCCESS)
+ WLog_ERR(TAG, "Failed to check FreeRDP event handles");
+
+ break;
+ }
+ }
+
+disconnect:
+ freerdp_disconnect(instance);
+ return result;
+}
+
+/* Optional global initializer.
+ * Here we just register a signal handler to print out stack traces
+ * if available. */
+static BOOL tf_client_global_init(void)
+{
+ if (freerdp_handle_signals() != 0)
+ return FALSE;
+
+ return TRUE;
+}
+
+/* Optional global tear down */
+static void tf_client_global_uninit(void)
+{
+}
+
+static int tf_logon_error_info(freerdp* instance, UINT32 data, UINT32 type)
+{
+ tfContext* tf = NULL;
+ const char* str_data = freerdp_get_logon_error_info_data(data);
+ const char* str_type = freerdp_get_logon_error_info_type(type);
+
+ if (!instance || !instance->context)
+ return -1;
+
+ tf = (tfContext*)instance->context;
+ WLog_INFO(TAG, "Logon Error Info %s [%s]", str_data, str_type);
+ WINPR_UNUSED(tf);
+
+ return 1;
+}
+
+static BOOL tf_client_new(freerdp* instance, rdpContext* context)
+{
+ tfContext* tf = (tfContext*)context;
+
+ if (!instance || !context)
+ return FALSE;
+
+ instance->PreConnect = tf_pre_connect;
+ instance->PostConnect = tf_post_connect;
+ instance->PostDisconnect = tf_post_disconnect;
+ instance->LogonErrorInfo = tf_logon_error_info;
+ /* TODO: Client display set up */
+ WINPR_UNUSED(tf);
+ return TRUE;
+}
+
+static void tf_client_free(freerdp* instance, rdpContext* context)
+{
+ tfContext* tf = (tfContext*)instance->context;
+
+ if (!context)
+ return;
+
+ /* TODO: Client display tear down */
+ WINPR_UNUSED(tf);
+}
+
+static int tf_client_start(rdpContext* context)
+{
+ /* TODO: Start client related stuff */
+ WINPR_UNUSED(context);
+ return 0;
+}
+
+static int tf_client_stop(rdpContext* context)
+{
+ /* TODO: Stop client related stuff */
+ WINPR_UNUSED(context);
+ return 0;
+}
+
+static int RdpClientEntry(RDP_CLIENT_ENTRY_POINTS* pEntryPoints)
+{
+ WINPR_ASSERT(pEntryPoints);
+
+ ZeroMemory(pEntryPoints, sizeof(RDP_CLIENT_ENTRY_POINTS));
+ pEntryPoints->Version = RDP_CLIENT_INTERFACE_VERSION;
+ pEntryPoints->Size = sizeof(RDP_CLIENT_ENTRY_POINTS_V1);
+ pEntryPoints->GlobalInit = tf_client_global_init;
+ pEntryPoints->GlobalUninit = tf_client_global_uninit;
+ pEntryPoints->ContextSize = sizeof(tfContext);
+ pEntryPoints->ClientNew = tf_client_new;
+ pEntryPoints->ClientFree = tf_client_free;
+ pEntryPoints->ClientStart = tf_client_start;
+ pEntryPoints->ClientStop = tf_client_stop;
+ return 0;
+}
+
+int main(int argc, char* argv[])
+{
+ int rc = -1;
+ DWORD status = 0;
+ RDP_CLIENT_ENTRY_POINTS clientEntryPoints;
+ rdpContext* context = NULL;
+ RdpClientEntry(&clientEntryPoints);
+ context = freerdp_client_context_new(&clientEntryPoints);
+
+ if (!context)
+ goto fail;
+
+ status = freerdp_client_settings_parse_command_line(context->settings, argc, argv, FALSE);
+ if (status)
+ {
+ rc = freerdp_client_settings_command_line_status_print(context->settings, status, argc,
+ argv);
+ goto fail;
+ }
+
+ if (!stream_dump_register_handlers(context, CONNECTION_STATE_MCS_CREATE_REQUEST, FALSE))
+ goto fail;
+
+ if (freerdp_client_start(context) != 0)
+ goto fail;
+
+ rc = tf_client_thread_proc(context->instance);
+
+ if (freerdp_client_stop(context) != 0)
+ rc = -1;
+
+fail:
+ freerdp_client_context_free(context);
+ return rc;
+}
diff --git a/client/Sample/tf_freerdp.h b/client/Sample/tf_freerdp.h
new file mode 100644
index 0000000..c9b5295
--- /dev/null
+++ b/client/Sample/tf_freerdp.h
@@ -0,0 +1,37 @@
+/**
+ * FreeRDP: A Remote Desktop Protocol Implementation
+ * Sample Client
+ *
+ * Copyright 2018 Armin Novak <armin.novak@thincast.com>
+ * Copyright 2018 Thincast Technologies GmbH
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+#ifndef FREERDP_CLIENT_SAMPLE_H
+#define FREERDP_CLIENT_SAMPLE_H
+
+#include <freerdp/freerdp.h>
+#include <freerdp/client/rdpei.h>
+#include <freerdp/client/rail.h>
+#include <freerdp/client/cliprdr.h>
+#include <freerdp/client/rdpgfx.h>
+
+typedef struct
+{
+ rdpClientContext common;
+
+ /* Channels */
+} tfContext;
+
+#endif /* FREERDP_CLIENT_SAMPLE_H */