summaryrefslogtreecommitdiffstats
path: root/client/X11/cli
diff options
context:
space:
mode:
Diffstat (limited to 'client/X11/cli')
-rw-r--r--client/X11/cli/CMakeLists.txt20
-rw-r--r--client/X11/cli/xfreerdp.c21
2 files changed, 25 insertions, 16 deletions
diff --git a/client/X11/cli/CMakeLists.txt b/client/X11/cli/CMakeLists.txt
index 580337b..0761b2f 100644
--- a/client/X11/cli/CMakeLists.txt
+++ b/client/X11/cli/CMakeLists.txt
@@ -15,32 +15,20 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-set(MODULE_NAME "xfreerdp-cli")
+set(MODULE_NAME "xfreerdp")
set(MODULE_PREFIX "FREERDP_CLIENT_X11")
set(SRCS
- xfreerdp.c
+ xfreerdp.c
)
-add_executable(${MODULE_NAME} ${SRCS})
-
-if (WITH_BINARY_VERSIONING)
- set_target_properties(${MODULE_NAME} PROPERTIES OUTPUT_NAME "xfreerdp${PROJECT_VERSION_MAJOR}")
-else()
- set_target_properties(${MODULE_NAME} PROPERTIES OUTPUT_NAME "xfreerdp")
-endif()
+AddTargetWithResourceFile(${MODULE_NAME} TRUE "${PROJECT_VERSION}" SRCS)
set_target_properties(${MODULE_NAME} PROPERTIES RUNTIME_OUTPUT_DIRECTORY "..")
list(APPEND LIBS
- xfreerdp-client freerdp-client
+ xfreerdp-client
)
-if(OPENBSD)
- list(APPEND LIBS
- ossaudio
- )
-endif()
-
target_link_libraries(${MODULE_NAME} PRIVATE ${LIBS})
install(TARGETS ${MODULE_NAME} RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT client)
diff --git a/client/X11/cli/xfreerdp.c b/client/X11/cli/xfreerdp.c
index 33b2a96..4bdaf4c 100644
--- a/client/X11/cli/xfreerdp.c
+++ b/client/X11/cli/xfreerdp.c
@@ -31,6 +31,25 @@
#include "../xf_client.h"
#include "../xfreerdp.h"
+static void xfreerdp_print_help(void)
+{
+ printf("Keyboard Shortcuts:\n");
+ printf("\t<Right CTRL>\n");
+ printf("\t\treleases keyboard and mouse grab\n");
+ printf("\t<CTRL>+<ALT>+<Return>\n");
+ printf("\t\ttoggles fullscreen state of the application\n");
+ printf("\t<CTRL>+<ALT>+c\n");
+ printf("\t\ttoggles remote control in a remote assistance session\n");
+ printf("\tAction Script\n");
+ printf("\t\tExecutes a predefined script on key press.\n");
+ printf("\t\tShould the script not exist it is ignored.\n");
+ printf("\t\tScripts can be provided at the default localtion ~/.config/freerdp/action.sh or as "
+ "command line argument /action:script:<path>\n");
+ printf("\t\tThe script will receive the current key combination as argument.\n");
+ printf("\t\tThe output of the script is parsed for 'key-local' which tells that the script "
+ "used the key combination, otherwise the combination is forwarded to the remote.\n");
+}
+
int main(int argc, char* argv[])
{
int rc = 1;
@@ -59,6 +78,8 @@ int main(int argc, char* argv[])
{
rc = freerdp_client_settings_command_line_status_print(settings, status, argc, argv);
+ xfreerdp_print_help();
+
if (freerdp_settings_get_bool(settings, FreeRDP_ListMonitors))
xf_list_monitors(xfc);