summaryrefslogtreecommitdiffstats
path: root/libfreerdp/crypto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libfreerdp/crypto/CMakeLists.txt')
-rw-r--r--libfreerdp/crypto/CMakeLists.txt57
1 files changed, 57 insertions, 0 deletions
diff --git a/libfreerdp/crypto/CMakeLists.txt b/libfreerdp/crypto/CMakeLists.txt
new file mode 100644
index 0000000..16a73d6
--- /dev/null
+++ b/libfreerdp/crypto/CMakeLists.txt
@@ -0,0 +1,57 @@
+# FreeRDP: A Remote Desktop Protocol Implementation
+# libfreerdp-crypto cmake build script
+#
+# Copyright 2012 Marc-Andre Moreau <marcandre.moreau@gmail.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+set(MODULE_NAME "freerdp-crypto")
+set(MODULE_PREFIX "FREERDP_CRYPTO")
+
+freerdp_module_add(
+ er.c
+ der.c
+ ber.c
+ per.c
+ base64.c
+ x509_utils.c
+ x509_utils.h
+ cert_common.h
+ cert_common.c
+ privatekey.c
+ privatekey.h
+ certificate.c
+ certificate.h
+ certificate_data.c
+ certificate_store.c
+ crypto.c
+ tls.c
+ tls.h
+ opensslcompat.c)
+
+freerdp_include_directory_add(${OPENSSL_INCLUDE_DIR})
+
+freerdp_library_add(${OPENSSL_LIBRARIES})
+
+if(MBEDTLS_FOUND)
+ freerdp_include_directory_add(${MBEDTLS_INCLUDE_DIR})
+ freerdp_library_add(${MBEDTLS_LIBRARIES})
+endif()
+
+if(WIN32)
+ freerdp_library_add(ws2_32)
+endif()
+
+if(BUILD_TESTING)
+ add_subdirectory(test)
+endif()