summaryrefslogtreecommitdiffstats
path: root/winpr/libwinpr/security
diff options
context:
space:
mode:
Diffstat (limited to 'winpr/libwinpr/security')
-rw-r--r--winpr/libwinpr/security/CMakeLists.txt22
-rw-r--r--winpr/libwinpr/security/ModuleOptions.cmake8
-rw-r--r--winpr/libwinpr/security/security.c226
-rw-r--r--winpr/libwinpr/security/security.h45
-rw-r--r--winpr/libwinpr/security/test/CMakeLists.txt23
-rw-r--r--winpr/libwinpr/security/test/TestSecurityToken.c9
6 files changed, 333 insertions, 0 deletions
diff --git a/winpr/libwinpr/security/CMakeLists.txt b/winpr/libwinpr/security/CMakeLists.txt
new file mode 100644
index 0000000..98141e1
--- /dev/null
+++ b/winpr/libwinpr/security/CMakeLists.txt
@@ -0,0 +1,22 @@
+# WinPR: Windows Portable Runtime
+# libwinpr-security cmake build script
+#
+# Copyright 2012 Marc-Andre Moreau <marcandre.moreau@gmail.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+winpr_module_add(security.c)
+
+if(BUILD_TESTING)
+ add_subdirectory(test)
+endif()
diff --git a/winpr/libwinpr/security/ModuleOptions.cmake b/winpr/libwinpr/security/ModuleOptions.cmake
new file mode 100644
index 0000000..66fa71a
--- /dev/null
+++ b/winpr/libwinpr/security/ModuleOptions.cmake
@@ -0,0 +1,8 @@
+
+set(MINWIN_LAYER "1")
+set(MINWIN_GROUP "security")
+set(MINWIN_MAJOR_VERSION "2")
+set(MINWIN_MINOR_VERSION "0")
+set(MINWIN_SHORT_NAME "base")
+set(MINWIN_LONG_NAME "Base Security Functions")
+set(MODULE_LIBRARY_NAME "api-ms-win-${MINWIN_GROUP}-${MINWIN_SHORT_NAME}-l${MINWIN_LAYER}-${MINWIN_MAJOR_VERSION}-${MINWIN_MINOR_VERSION}")
diff --git a/winpr/libwinpr/security/security.c b/winpr/libwinpr/security/security.c
new file mode 100644
index 0000000..3806233
--- /dev/null
+++ b/winpr/libwinpr/security/security.c
@@ -0,0 +1,226 @@
+/**
+ * WinPR: Windows Portable Runtime
+ * Base Security Functions
+ *
+ * Copyright 2013 Marc-Andre Moreau <marcandre.moreau@gmail.com>
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+#include <winpr/config.h>
+
+#include <winpr/crt.h>
+
+#ifdef WINPR_HAVE_UNISTD_H
+#include <unistd.h>
+#endif
+
+#include <winpr/security.h>
+
+#include "../handle/handle.h"
+
+/**
+ * api-ms-win-security-base-l1-2-0.dll:
+ *
+ * AccessCheck
+ * AccessCheckAndAuditAlarmW
+ * AccessCheckByType
+ * AccessCheckByTypeAndAuditAlarmW
+ * AccessCheckByTypeResultList
+ * AccessCheckByTypeResultListAndAuditAlarmByHandleW
+ * AccessCheckByTypeResultListAndAuditAlarmW
+ * AddAccessAllowedAce
+ * AddAccessAllowedAceEx
+ * AddAccessAllowedObjectAce
+ * AddAccessDeniedAce
+ * AddAccessDeniedAceEx
+ * AddAccessDeniedObjectAce
+ * AddAce
+ * AddAuditAccessAce
+ * AddAuditAccessAceEx
+ * AddAuditAccessObjectAce
+ * AddMandatoryAce
+ * AddResourceAttributeAce
+ * AddScopedPolicyIDAce
+ * AdjustTokenGroups
+ * AdjustTokenPrivileges
+ * AllocateAndInitializeSid
+ * AllocateLocallyUniqueId
+ * AreAllAccessesGranted
+ * AreAnyAccessesGranted
+ * CheckTokenCapability
+ * CheckTokenMembership
+ * CheckTokenMembershipEx
+ * ConvertToAutoInheritPrivateObjectSecurity
+ * CopySid
+ * CreatePrivateObjectSecurity
+ * CreatePrivateObjectSecurityEx
+ * CreatePrivateObjectSecurityWithMultipleInheritance
+ * CreateRestrictedToken
+ * CreateWellKnownSid
+ * DeleteAce
+ * DestroyPrivateObjectSecurity
+ * DuplicateToken
+ * DuplicateTokenEx
+ * EqualDomainSid
+ * EqualPrefixSid
+ * EqualSid
+ * FindFirstFreeAce
+ * FreeSid
+ * GetAce
+ * GetAclInformation
+ * GetAppContainerAce
+ * GetCachedSigningLevel
+ * GetFileSecurityW
+ * GetKernelObjectSecurity
+ * GetLengthSid
+ * GetPrivateObjectSecurity
+ * GetSidIdentifierAuthority
+ * GetSidLengthRequired
+ * GetSidSubAuthority
+ * GetSidSubAuthorityCount
+ * GetTokenInformation
+ * GetWindowsAccountDomainSid
+ * ImpersonateAnonymousToken
+ * ImpersonateLoggedOnUser
+ * ImpersonateSelf
+ * InitializeAcl
+ * InitializeSid
+ * IsTokenRestricted
+ * IsValidAcl
+ * IsValidSid
+ * IsWellKnownSid
+ * MakeAbsoluteSD
+ * MakeSelfRelativeSD
+ * MapGenericMask
+ * ObjectCloseAuditAlarmW
+ * ObjectDeleteAuditAlarmW
+ * ObjectOpenAuditAlarmW
+ * ObjectPrivilegeAuditAlarmW
+ * PrivilegeCheck
+ * PrivilegedServiceAuditAlarmW
+ * QuerySecurityAccessMask
+ * RevertToSelf
+ * SetAclInformation
+ * SetCachedSigningLevel
+ * SetFileSecurityW
+ * SetKernelObjectSecurity
+ * SetPrivateObjectSecurity
+ * SetPrivateObjectSecurityEx
+ * SetSecurityAccessMask
+ * SetTokenInformation
+ */
+
+#ifndef _WIN32
+
+#include "security.h"
+
+BOOL InitializeSecurityDescriptor(PSECURITY_DESCRIPTOR pSecurityDescriptor, DWORD dwRevision)
+{
+ return TRUE;
+}
+
+DWORD GetSecurityDescriptorLength(PSECURITY_DESCRIPTOR pSecurityDescriptor)
+{
+ return 0;
+}
+
+BOOL IsValidSecurityDescriptor(PSECURITY_DESCRIPTOR pSecurityDescriptor)
+{
+ return TRUE;
+}
+
+BOOL GetSecurityDescriptorControl(PSECURITY_DESCRIPTOR pSecurityDescriptor,
+ PSECURITY_DESCRIPTOR_CONTROL pControl, LPDWORD lpdwRevision)
+{
+ return TRUE;
+}
+
+BOOL SetSecurityDescriptorControl(PSECURITY_DESCRIPTOR pSecurityDescriptor,
+ SECURITY_DESCRIPTOR_CONTROL ControlBitsOfInterest,
+ SECURITY_DESCRIPTOR_CONTROL ControlBitsToSet)
+{
+ return TRUE;
+}
+
+BOOL GetSecurityDescriptorDacl(PSECURITY_DESCRIPTOR pSecurityDescriptor, LPBOOL lpbDaclPresent,
+ PACL* pDacl, LPBOOL lpbDaclDefaulted)
+{
+ return TRUE;
+}
+
+BOOL SetSecurityDescriptorDacl(PSECURITY_DESCRIPTOR pSecurityDescriptor, BOOL bDaclPresent,
+ PACL pDacl, BOOL bDaclDefaulted)
+{
+ return TRUE;
+}
+
+BOOL GetSecurityDescriptorGroup(PSECURITY_DESCRIPTOR pSecurityDescriptor, PSID* pGroup,
+ LPBOOL lpbGroupDefaulted)
+{
+ return TRUE;
+}
+
+BOOL SetSecurityDescriptorGroup(PSECURITY_DESCRIPTOR pSecurityDescriptor, PSID pGroup,
+ BOOL bGroupDefaulted)
+{
+ return TRUE;
+}
+
+BOOL GetSecurityDescriptorOwner(PSECURITY_DESCRIPTOR pSecurityDescriptor, PSID* pOwner,
+ LPBOOL lpbOwnerDefaulted)
+{
+ return TRUE;
+}
+
+BOOL SetSecurityDescriptorOwner(PSECURITY_DESCRIPTOR pSecurityDescriptor, PSID pOwner,
+ BOOL bOwnerDefaulted)
+{
+ return TRUE;
+}
+
+DWORD GetSecurityDescriptorRMControl(PSECURITY_DESCRIPTOR SecurityDescriptor, PUCHAR RMControl)
+{
+ return 0;
+}
+
+DWORD SetSecurityDescriptorRMControl(PSECURITY_DESCRIPTOR SecurityDescriptor, PUCHAR RMControl)
+{
+ return 0;
+}
+
+BOOL GetSecurityDescriptorSacl(PSECURITY_DESCRIPTOR pSecurityDescriptor, LPBOOL lpbSaclPresent,
+ PACL* pSacl, LPBOOL lpbSaclDefaulted)
+{
+ return TRUE;
+}
+
+BOOL SetSecurityDescriptorSacl(PSECURITY_DESCRIPTOR pSecurityDescriptor, BOOL bSaclPresent,
+ PACL pSacl, BOOL bSaclDefaulted)
+{
+ return TRUE;
+}
+
+#endif
+
+BOOL AccessTokenIsValid(HANDLE handle)
+{
+ WINPR_HANDLE* h = (WINPR_HANDLE*)handle;
+
+ if (!h || (h->Type != HANDLE_TYPE_ACCESS_TOKEN))
+ {
+ SetLastError(ERROR_INVALID_PARAMETER);
+ return FALSE;
+ }
+ return TRUE;
+}
diff --git a/winpr/libwinpr/security/security.h b/winpr/libwinpr/security/security.h
new file mode 100644
index 0000000..a80dfe1
--- /dev/null
+++ b/winpr/libwinpr/security/security.h
@@ -0,0 +1,45 @@
+/**
+ * WinPR: Windows Portable Runtime
+ * Base Security Functions
+ *
+ * Copyright 2013 Marc-Andre Moreau <marcandre.moreau@gmail.com>
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+#ifndef WINPR_SECURITY_PRIVATE_H
+#define WINPR_SECURITY_PRIVATE_H
+
+#ifndef _WIN32
+
+#include <winpr/security.h>
+
+#include "../handle/handle.h"
+
+struct winpr_access_token
+{
+ WINPR_HANDLE common;
+
+ LPSTR Username;
+ LPSTR Domain;
+
+ DWORD UserId;
+ DWORD GroupId;
+};
+typedef struct winpr_access_token WINPR_ACCESS_TOKEN;
+
+BOOL AccessTokenIsValid(HANDLE handle);
+
+#endif
+
+#endif /* WINPR_SECURITY_PRIVATE_H */
diff --git a/winpr/libwinpr/security/test/CMakeLists.txt b/winpr/libwinpr/security/test/CMakeLists.txt
new file mode 100644
index 0000000..80be394
--- /dev/null
+++ b/winpr/libwinpr/security/test/CMakeLists.txt
@@ -0,0 +1,23 @@
+
+set(MODULE_NAME "TestSecurity")
+set(MODULE_PREFIX "TEST_SECURITY")
+
+set(${MODULE_PREFIX}_DRIVER ${MODULE_NAME}.c)
+
+set(${MODULE_PREFIX}_TESTS
+ TestSecurityToken.c)
+
+create_test_sourcelist(${MODULE_PREFIX}_SRCS
+ ${${MODULE_PREFIX}_DRIVER}
+ ${${MODULE_PREFIX}_TESTS})
+
+add_executable(${MODULE_NAME} ${${MODULE_PREFIX}_SRCS})
+
+set_target_properties(${MODULE_NAME} PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${TESTING_OUTPUT_DIRECTORY}")
+
+foreach(test ${${MODULE_PREFIX}_TESTS})
+ get_filename_component(TestName ${test} NAME_WE)
+ add_test(${TestName} ${TESTING_OUTPUT_DIRECTORY}/${MODULE_NAME} ${TestName})
+endforeach()
+
+set_property(TARGET ${MODULE_NAME} PROPERTY FOLDER "WinPR/Test")
diff --git a/winpr/libwinpr/security/test/TestSecurityToken.c b/winpr/libwinpr/security/test/TestSecurityToken.c
new file mode 100644
index 0000000..0d877b6
--- /dev/null
+++ b/winpr/libwinpr/security/test/TestSecurityToken.c
@@ -0,0 +1,9 @@
+
+#include <winpr/crt.h>
+#include <winpr/tchar.h>
+#include <winpr/security.h>
+
+int TestSecurityToken(int argc, char* argv[])
+{
+ return 0;
+}