summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 01:07:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 01:07:32 +0000
commit02459d98dddf1afc33c34c2042c3428a4a718a1f (patch)
tree830dfd72ba7d9fcf070651396c3b4aa7af34750b
parentAdding debian version 10.0-1. (diff)
downloadfrr-debian/10.0-2.tar.xz
frr-debian/10.0-2.zip
Adding debian version 10.0-2.debian/10.0-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog9
-rw-r--r--debian/control9
-rw-r--r--debian/frr.postrm1
-rw-r--r--debian/patches/add-XREF_SETUP-to-libraries-and-utilites.patch72
-rw-r--r--debian/patches/series1
-rw-r--r--debian/watch9
6 files changed, 88 insertions, 13 deletions
diff --git a/debian/changelog b/debian/changelog
index d631eec..00ce448 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+frr (10.0-2) unstable; urgency=medium
+
+ * fix build on hppa
+ * only use libunwind on architectures where it is available
+ * remove /var/lib/frr on purge
+ * drop some ancient dependency alternates
+
+ -- David Lamparter <equinox-debian@diac24.net> Fri, 03 May 2024 14:53:50 +0200
+
frr (10.0-1) unstable; urgency=medium
* IRDP module is no longer packaged (slated to be removed upstream)
diff --git a/debian/control b/debian/control
index 0e7c277..df816df 100644
--- a/debian/control
+++ b/debian/control
@@ -6,8 +6,7 @@ Uploaders: FRRouting-dev <dev@lists.frrouting.org>,
Ondřej Surý <ondrej@debian.org>
Build-Depends: bison,
chrpath,
- debhelper (>= 10~) | dh-systemd,
- debhelper (>= 9.20150101~),
+ debhelper (>= 10~),
flex,
gawk,
install-info,
@@ -15,7 +14,7 @@ Build-Depends: bison,
libcap-dev,
libelf-dev:native,
libjson-c-dev | libjson0-dev,
- libpam0g-dev | libpam-dev,
+ libpam0g-dev,
libpcre2-dev,
libprotobuf-c-dev,
libpython3-dev:native,
@@ -23,9 +22,9 @@ Build-Depends: bison,
librtr-dev (>= 0.8.0~) <!pkg.frr.nortrlib>,
libsnmp-dev,
libssh-dev <!pkg.frr.nortrlib>,
- libunwind-dev,
+ libunwind-dev [!alpha !m68k !sparc64 !x32],
libyang2-dev (>= 2.1.128),
- pkgconf | pkg-config,
+ pkgconf,
protobuf-c-compiler,
python3:native,
python3-dev:native,
diff --git a/debian/frr.postrm b/debian/frr.postrm
index 018f59e..c553abd 100644
--- a/debian/frr.postrm
+++ b/debian/frr.postrm
@@ -5,6 +5,7 @@ rm -f /etc/frr/.pkg.frr.nointegrated
if [ "$1" = "purge" ]; then
rm -rf /run/frr || true
+ rm -rf /var/lib/frr || true
# "purge" does not remove logfiles. therefore we shouldn't delete
# the "frr" user/group since that would leave files with "dangling"
diff --git a/debian/patches/add-XREF_SETUP-to-libraries-and-utilites.patch b/debian/patches/add-XREF_SETUP-to-libraries-and-utilites.patch
new file mode 100644
index 0000000..7237e4d
--- /dev/null
+++ b/debian/patches/add-XREF_SETUP-to-libraries-and-utilites.patch
@@ -0,0 +1,72 @@
+From 3ca60d00b1a3ca3822db5fcf6ba46cf3ac0a6b0b Mon Sep 17 00:00:00 2001
+From: David Lamparter <equinox@opensourcerouting.org>
+Date: Thu, 2 May 2024 10:55:11 +0200
+Subject: [PATCH] *: add XREF_SETUP() to libraries and utilites
+
+This is theoretically not needed if neither DEFUNs nor zlog_* calls are
+used, except I'm about to turn it into a build error to catch the cases
+where it _is_ necessary. Which is libmgmt_be_nb.la in this case, where
+it causes build failures on hppa.
+
+Signed-off-by: David Lamparter <equinox@opensourcerouting.org>
+---
+ fpm/fpm_pb.c | 5 +++++
+ mgmtd/mgmt_be_nb.c | 6 ++++++
+ mgmtd/subdir.am | 1 +
+ qpb/qpb.c | 5 +++++
+ 4 files changed, 17 insertions(+)
+ create mode 100644 mgmtd/mgmt_be_nb.c
+
+diff --git a/fpm/fpm_pb.c b/fpm/fpm_pb.c
+index e4c9395a84a6..0e8f618c4d3c 100644
+--- a/fpm/fpm_pb.c
++++ b/fpm/fpm_pb.c
+@@ -10,3 +10,8 @@
+ /*
+ * Main file for the fpm_pb library.
+ */
++
++#include "config.h"
++#include "xref.h"
++
++XREF_SETUP();
+diff --git a/mgmtd/mgmt_be_nb.c b/mgmtd/mgmt_be_nb.c
+new file mode 100644
+index 000000000000..613272d40728
+--- /dev/null
++++ b/mgmtd/mgmt_be_nb.c
+@@ -0,0 +1,6 @@
++// SPDX-License-Identifier: GPL-2.0-or-later
++
++#include "config.h"
++#include "xref.h"
++
++XREF_SETUP();
+diff --git a/mgmtd/subdir.am b/mgmtd/subdir.am
+index 5182c4a47d37..14544c4f0507 100644
+--- a/mgmtd/subdir.am
++++ b/mgmtd/subdir.am
+@@ -16,6 +16,7 @@ clippy_scan += \
+
+ lib_LTLIBRARIES += mgmtd/libmgmt_be_nb.la
+ mgmtd_libmgmt_be_nb_la_SOURCES = \
++ mgmtd/mgmt_be_nb.c \
+ zebra/zebra_cli.c \
+ # end
+ nodist_mgmtd_libmgmt_be_nb_la_SOURCES = \
+diff --git a/qpb/qpb.c b/qpb/qpb.c
+index 63454f115666..625817857819 100644
+--- a/qpb/qpb.c
++++ b/qpb/qpb.c
+@@ -10,3 +10,8 @@
+ /*
+ * Main file for the qpb library.
+ */
++
++#include "config.h"
++#include "xref.h"
++
++XREF_SETUP();
+--
+2.43.0
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..2e44dfb
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+add-XREF_SETUP-to-libraries-and-utilites.patch
diff --git a/debian/watch b/debian/watch
index 2485a0d..dc2b46a 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,10 +1,3 @@
version=4
-opts="\
-searchmode=plain,\
-uversionmangle=s/(\d)[_\.\-\+]?((RC|rc|pre|dev|beta|alpha)\d*)$/$1~$2/,\
-downloadurlmangle=s&releases/>FRR\s*(\d\S+)\s+Release<&archive/refs/tags/frr-$1.tar.gz&,\
-filenamemangle=s&>FRR\s*(\d\S+)\s+Release<&frr-$1.tar.gz&,\
-" \
-https://github.com/FRRouting/frr/releases/ \
- >FRR\s*(\d\S+)\s+Release<
+https://github.com/FRRouting/frr/tags .*/frr-(\d[0-9.]*)\.tar.gz