summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 1 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index d18f144..fa0e7be 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,10 +4,6 @@
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-ifneq (,$(filter $(DEB_HOST_ARCH), armel m68k mipsel powerpc sh4))
- export DEB_LDFLAGS_MAINT_APPEND += -Wl,--no-as-needed -latomic -Wl,--as-needed
-endif
-
ifneq (,$(filter terse,$(DEB_BUILD_OPTIONS)))
MAKE_SILENT="V=0"
export DH_VERBOSE=0
@@ -43,11 +39,9 @@ export PYTHON=python3
dh $@ -Bbuild --with=sphinxdoc
override_dh_auto_configure:
- $(shell dpkg-buildflags --export=sh); \
+ $(shell dpkg-buildflags --export=sh); export LIBS="$$LIBS -latomic"; \
dh_auto_configure -- \
- --localstatedir=/var/run/frr \
--sbindir=/usr/lib/frr \
- --sysconfdir=/etc/frr \
--with-vtysh-pager=/usr/bin/pager \
--libdir=/usr/lib/$(DEB_HOST_MULTIARCH)/frr \
--with-moduledir=/usr/lib/$(DEB_HOST_MULTIARCH)/frr/modules \
@@ -60,7 +54,6 @@ override_dh_auto_configure:
--with-libpam \
--enable-doc \
--enable-doc-html \
- --enable-irdp \
--enable-snmp \
--enable-fpm \
--disable-protobuf \