summaryrefslogtreecommitdiffstats
path: root/doc/user/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'doc/user/Makefile')
-rw-r--r--doc/user/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/doc/user/Makefile b/doc/user/Makefile
new file mode 100644
index 0000000..840ee5b
--- /dev/null
+++ b/doc/user/Makefile
@@ -0,0 +1,16 @@
+all: ALWAYS
+ @$(MAKE) -s -C ../.. doc-user
+help: ALWAYS
+ @$(MAKE) -s -C ../.. doc/help
+pdf: ALWAYS
+ @$(MAKE) -s -C ../.. doc/user/_build/latexpdf
+info: ALWAYS
+ @$(MAKE) -s -C ../.. doc/user/_build/texinfo/frr.info
+%: ALWAYS
+ @$(MAKE) -s -C ../.. doc/user/_build/$@
+
+Makefile:
+ #nothing
+ALWAYS:
+.PHONY: ALWAYS makefiles
+.SUFFIXES: