summaryrefslogtreecommitdiffstats
path: root/docker/alpine
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--docker/alpine/Dockerfile9
-rwxr-xr-xdocker/alpine/libyang/APKBUILD2
2 files changed, 5 insertions, 6 deletions
diff --git a/docker/alpine/Dockerfile b/docker/alpine/Dockerfile
index 98e8407..1cff06f 100644
--- a/docker/alpine/Dockerfile
+++ b/docker/alpine/Dockerfile
@@ -1,7 +1,7 @@
# syntax=docker/dockerfile:1
# Create a basic stage set up to build APKs
-FROM alpine:3.18 as alpine-builder
+FROM alpine:3.19 as alpine-builder
RUN apk add \
--update-cache \
abuild \
@@ -24,7 +24,7 @@ RUN cd /src/libyang \
&& abuild -r -P /pkgs/apk
# This stage builds a dist tarball from the source
-FROM alpine:3.18 as source-builder
+FROM alpine:3.19 as source-builder
RUN mkdir -p /src/alpine /pkgs/apk
COPY alpine/APKBUILD.in /src/alpine
COPY --from=alpine-apk-builder-libyang /pkgs/apk/src /pkgs/apk
@@ -33,8 +33,7 @@ RUN source /src/alpine/APKBUILD.in \
&& apk add \
--no-cache \
--update-cache \
- $makedepends \
- && pip install pytest
+ $makedepends
COPY . /src
ARG PKGVER
RUN cd /src \
@@ -58,7 +57,7 @@ RUN cd /dist \
&& abuild -r -P /pkgs/apk
# This stage installs frr from the apk
-FROM alpine:3.18
+FROM alpine:3.19
RUN mkdir -p /pkgs/apk
COPY --from=alpine-apk-builder /pkgs/apk/ /pkgs/apk/
RUN apk add \
diff --git a/docker/alpine/libyang/APKBUILD b/docker/alpine/libyang/APKBUILD
index 04e943f..6973fd6 100755
--- a/docker/alpine/libyang/APKBUILD
+++ b/docker/alpine/libyang/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Christian Franke <nobody@nowhere.ws>
pkgname=libyang
-pkgver=2.1.80
+pkgver=2.1.128
pkgrel=0
pkgdesc="YANG data modelling language parser and toolkit"
url="https://github.com/CESNET/libyang"