summaryrefslogtreecommitdiffstats
path: root/debian/patches/kfreebsd-decimal-float.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/kfreebsd-decimal-float.diff')
-rw-r--r--debian/patches/kfreebsd-decimal-float.diff32
1 files changed, 32 insertions, 0 deletions
diff --git a/debian/patches/kfreebsd-decimal-float.diff b/debian/patches/kfreebsd-decimal-float.diff
new file mode 100644
index 0000000..8149103
--- /dev/null
+++ b/debian/patches/kfreebsd-decimal-float.diff
@@ -0,0 +1,32 @@
+# DP: Enable decimal float support on kfreebsd-amd64
+
+--- a/src/gcc/configure.ac
++++ b/src/gcc/configure.ac
+@@ -927,6 +927,7 @@ AC_ARG_ENABLE(__cxa_atexit,
+ [], [])
+
+ # Enable C extension for decimal float if target supports it.
++# touch the file, adding decimal support for kfreebsd-amd64 in config/dfp.m4
+ GCC_AC_ENABLE_DECIMAL_FLOAT([$target])
+
+ dfp=`if test $enable_decimal_float != no; then echo 1; else echo 0; fi`
+--- a/src/libdecnumber/configure.ac
++++ b/src/libdecnumber/configure.ac
+@@ -77,6 +77,7 @@ AC_CANONICAL_TARGET
+
+ # Default decimal format
+ # If you change the defaults here, be sure to change them in the GCC directory also
++# touch the file, adding decimal support for kfreebsd-amd64 in config/dfp.m4
+ AC_MSG_CHECKING([for decimal floating point])
+
+ GCC_AC_ENABLE_DECIMAL_FLOAT([$target])
+--- a/src/libgcc/configure.ac
++++ b/src/libgcc/configure.ac
+@@ -235,6 +235,7 @@ AC_CHECK_HEADERS(inttypes.h stdint.h std
+ AC_HEADER_STDC
+
+ # Check for decimal float support.
++# touch the file, adding decimal support for kfreebsd-amd64 in config/dfp.m4
+ AC_CACHE_CHECK([whether decimal floating point is supported], [libgcc_cv_dfp],
+ [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <fenv.h>